Soft vs hard reboot, when soft, device and services offline

I am already afraid to reboot for any reason since only a hard reboot (unplug) brings the RUT240 back online with all services. So, since the device is actually remote, I cannot really do any serious configs, updates or changes without losing connection until someone goes onsite (remote)
FW: RUT2XX_R_00.01.14.5


Welcome to the Teltonika Community :smiley:

Regarding your query, Can you kindly specify the issue you are facing so we can troubleshoot

Please revert to us in case the issue persists


as mentioned, I’d be glad to assist in troubleshooting, however, I won’t be onsite for a few days… if the logs after the next hard reboot still exist, I will submit the restart logs … meanwhile, it’s very annoying not being able to maintain/control any equipment after any soft reboot. I think the APN may be part of the issue … but that did not happen before (last year) … still could be ::slight_smile:


If the worry is for setting up an APN remotely, you could use the capability of our RutOS called SMS Utilities, where by you can send an SMS to the Router, and change configuration

For example for setting up APN remotely through SMS, Go to Services>Mobile Utiilities>SMS Utilities

and your SMS should look something like this

router_password cellular apn=your_apn

for you’re reference kindly go through this

Let us Know if this solves your remote configuration issue


hi, thanks. This is cool to know and a great utility, however, this is not the problem, the router has been running for many years already. The problem is the soft reboot, triggered by an update or manual, or auto … vs. hard, when unplug and re-power, all services come up fine, whereas the soft reboot doesn´t come up clean, so I am offline for several days already again until someone goes onsite to unplug …

The FW we are currently at is 7.06.1, many of the known bugs as well as features were added in multiple updates for the device, unfortunately the device you are using is i still in Legacy fw,
latest fw

Since the update is a major one, there might be some issues encountered, if so what we would suggest is to redo the config

Note: Before doing the firmware upgrade we would like you, to take a copy of the device’s backup and troubleshoot file in order to secure a copy of your current configuration.

Note: Doing the firmware upgrade without “Keep settings” option ON will wipe out all existing configurations, and device might lose remote connectivity. Therefore, it is advisable to perform the firmware upgrade when the device is physically accessible to you or if you can ensure remote access through RMS or SMS Utilities as backup access.

Kindly find the possibility to update firmware the next time a person in onsite, and test,
This should in theory solve most of the issues , but do let us know if it persists after an update

wow, legacy? :slight_smile: I though the …1.14.7 was the latest. Ok, I will do a backup and run the FW updates sequential (whenever I get there)

Hello, this is awesome, I just didn’t spend enough time to read into this. The SMS utility actually worked, device reboot was successful :slight_smile: Thx. Surely I will patch the 240 with the latest FW.

1 Like


Glad it worked :innocent:, let us know if any issues persist

Best Regards

This topic was automatically closed after 15 days. New replies are no longer allowed.