Send RUT955 GPS to GPS-Server

I am attempting to send the GPS location of my router to the service provided by GPS-Server. I have set up the object in the GPS-Server software (the IEMI of the modem in the RUT955). I enabled all 3 positioning systems in the RUT955 software along with the ip address of the GPS-Server server, port 11922 etc but the GPS-Server still does not receive data.

Would anyone have the full settings I need to make?

Regards, Paul

What are you actually trying to achieve? Could you define what you refer to as “GPS-Server”?

I have subscribed to the service “GPS-Server”. I would like to send my router’s position to this GPS-Server so I can see its position.
I have the URL and port number of the GPS-Server server.
What I am not sure of are the RUT955 settings to enable the positioning data to be sent to the GPS-Server server.
Regards, Paul

Hello Paul,

Ok understand what you are trying to do but something I have not done or need to do but from what I understand, obviously the router Service>GPS>General>GPS Configuration needs to be Enabled, which you would no doubt have Enabled, check using the GPS>Map that the GPS is working and the router is fact located where it is supposed to be.

From my quick browse of GPS-Server you should have entered the router IMEI when you created your account etc and you have the IP/URL and Port # relative to your account etc

Ok you then appear to need to Enable Services>GPS>AVL input the host information you have, Save/Apply and see what happens?

Another way to track your router is via Teltonika RMS, remote login to the GPS page.


Let’s divide your query into 2 steps.
1-)Receiving the GPS data of your router.
2-)Sending your router’s GPS data to Server.

For the first step to be done, you have to enable the GPS from the WebUI.
It can be reached from the Services > GPS > General Settings

After it’s enabled, can you please check how many satellites are visible.
You should run this command on CLI: gpsctl -p

Please let me know about the updates!


Thank you. I have got it working now. It was the AVL section that I had not completed.

Really appreciate all the help received.

Regards, Paul

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.