Seemingly dead RUT240 working briefly

Hello, my RUT240 has stopped working properly. My situation is almost identical to the one the author of the post Recovering dead RUT240's - No status LEDs - Crowd Support Forum | Teltonika Networks describes. The RUT240 doesn’t appear on the list of available networks, nor does anything happen when I try to establish an Ethernet connection to my PC: booting up “cmd” on Windows and using the “ipconfig” command it doesn’t even show an IP, it’s as if it’s completely dead. Also of note is the fact that the only two LEDs that work are the Power LED, that is working normally, and the LAN LED, which shows a very faint light. There is absolutely nothing showing on the remaining LEDs, neither on the WAN LED nor on the signal strength indicator LED. I have also tried pressing the reset button, and nothing happens.
However, there is a significant difference, hence the need to create this new topic: on a different location with a different power supply, the RUT240 briefly worked. It was working as it should, the LEDs were functioning properly and its firmware was even successfully updated. But, after switching to yet another power supply, and only then, it stopped working, and returned to its previous state: not showing up in available wireless networks, no Ethernet connection, only showing the Power LED properly and a faint light on the LAN LED, etc. It reverted to its previous malfunctioning state.
The problem doesn’t lie with the new power supply, as there is even a RUT230 working as intended using that same power supply. Also, I tried using the previous power supply, the one the RUT240 worked briefly with, but this time the RUT240 simply appeared dead from the get go.
So, I have a seemingly dead RUT240 that sometimes works. Is there a way to find out what the problem is?


I recommend trying The bootloader menu: The bootloader menu is a special router state used as a recovery tool in case the router becomes inaccessible even after a factory reset. It can be used to upgrade the router’s firmware or bootloader version.

Please inform me if this recovery option helped resolve the issue.

Best Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.