RUTX50 Will not forward ANY ports


My RUTX50 will not forward a single port. I am an IT Engineer of 35 years and my friend and colleague the same for 30 years. Between us we have spent 6 hours trying to forward a couple of ports with zero success.

The router was on


I have downgraded all the way to


Still, no ports will forward.

We tried every combination possible, performed at least 5 factory resets to start fresh

We tried the following commands to allow all traffic
iptables -I INPUT -j ACCEPT - to accept ALL connections, and then
iptables -I FORWARD -j ACCEPT - to forward all traffic.

we also tried disabling the firewall completely with

/etc/init.d/firewall stop

I have another 4G router (Huwaeii) and using the same sim card it works fine!

As I have tried at least 4 different firmwares I cannot help but feel I am missing something but everywhere I look I should only be using the port forward section.

If anyone can offer some advice I would really appreciate it!


To set up a port forward, you only need a port forward rule and to open the ports on both the device you’re forwarding from and the one you’re forwarding to.

Here’s an example of how to set up a port forward rule to forward HTTP traffic from WAN to another device connected to the RUTX50 on port 80:

I hope this helps. If you’re still experiencing issues, feel free to reach out again.

Best regards,

Many thanks for your reply!

Unfortunately, this is not working for me.

Please see the screenshots below, I am in this example trying to forward 2 ports (80,8096)

I have factory reset once again and just added the port forwarding

I look forward to your reply & again, many thanks!


Have you opened these ports on RUTX50? I have shown how to do it for port 80 in the post above.

For other port traffic, a rule will be needed:

  • Go to Network → Firewall → Traffic Rules and scroll to the bottom of the page.
  • Create rules as shown in the picture below. And enable it.

Best regards,


Yes, I enabled http (80) sorry, didn’t include the screenshot. Added the traffic rule for 8096, waited 5 mins and still closed.


As you have already set port forwarding on RUTX50, now those specific ports are forwarded to your end device and if ports are not open there, then these ports are still shown as closed.

Have you at least been able to reach your router via 80/443 from WAN?

Best regards,


Thank you for your patience,

For this test I just have the RUTX50 connected directly to my ubuntu machine (fresh install)

If I type the wan address with :80 or :443 :8096 on either the ubuntu machine or any other internet enabled machine I get the " This site can’t be reached" error

I just cannot get any ports at all to open/forward?

Just to ensure I am doing this correctly, I am going to websites that show my ip address (like whatsmyip) and that is the address I am entering before :80 etc so for example

do you get public IP on your SIM card? Did you get same IP address like Huawei router does? If not you should check your APN.
Next thing to look, does your ubuntu PC can reach internet and respond to public IPs?
Rules looks good, you can try to tcpdump interface on ubuntu PC and see if you get packets to it and if it respond.

Thank you so much! I had to change the APN! All working great!! again thanks!!