RutX50 upgrade has stopped programs connecting to the internet

Hi. I have recently upgraded my firmware on the RUTX50. Prior to the upgrade programs such as NordVPN, MT4 and BitDefender seamlessly connected to the internet. Since the upgrade none of these programs connect and I am mystified as to why. I am very much a newbie when it comes to this router so patience would be appreciated. I would happily “roll back” to the previous upgrade but I am not sure if this is possible.

I do have normal internet access via Chrome.

Details of the upgrade are:

Firmware version
Firmware build date
2024-02-29 12:19:47
Internal modem firmware version
Kernel version

Any assistance would be greatly appreciated.

Many thanks


Don’t know when or how long ago you updated the firmware, but there is now another firmware update to version RUTX_R_00.07.06.8.

I’d update the firmware again.

Thank you for your prompt response, much appreciated. Alas, it has made no difference and the aforementioned programmes are still not connecting to the internet. Thanks Gavin

I’m sure that someone more knowledgeable will offer help but probably after the BH W/E now.

I’m guessing that you’re using a laptop or a desktop Windows PC?

Whatever the device is and whatever the operating system is, it clearly has access to the internet and with this i’m confident that it isn’t a router issue but rather a coincidental problem.

If i were in your shoes, i’d start by removing NordVPN (Make sure that you have everything you need to download it and reinstall it again if you need to). Restart the device and see if MT4 and BitDefender have internet access. If the issue hasn’t resolved itself, remove BitDefender (Make sure that you have everything you need to download it and reinstall it again if you need to). Restart the device. Does MT4 have internet access?

If the issue hasn’t resolved itself, remove MT4 (Make sure that you have everything you need to download it and reinstall it again if you need to). Restart the device and reinstall MT4 first, restart and test it.

If it has internet access, you’re sorted, if not then this is the time to explore why elsewhere before you install anything else. I’d solve the issue with MT4 first before you reinstall NordVPN or BitDefender.

I would absolutely start by dumping any VPN software first. Don’t know which version of BitDefender you have but have you added BitDefenders VPN too, you could be running two VPN programs!?

Some firewall on the device you’re using or the routers’ firewall could also be blocking ports used by those programs so i’d then start by exploring the firewall on your device firstly then if that fails explore the routers integral firewall last


With version 07.06.x, default PDP type was changed to IPv4/IPv6, meaning that if the operator supports it, dual stack connection will be established (IPv4 and IPv6 addresses will be available).
Unfortunately, a lot of online services still do not support IPv6, and this could cause some issues when connecting to them.
To check if my theory is correct, please navigate to Network → WAN → edit the mob1s1a1 interface (SIM1), and change the PDP type to IPv4. If that helps, IPv4-only connection could be kept for now, as if you are not utilizing IPv6 compatibilities, there won’t be much benefit from looking for a workaround.
Let me know how it goes!

Best regards,

Hi Guys, Thank you so much for your replies, it is greatly appreciated that you are taking time ut to help me.

Let me try and answer all of the points raised in one response.

  1. moving from IPV4\IP6 to IPV4 resulted in complete loss of the internet.

  2. Regarding Bitdefender & NordVPN, fortunately I have a laptop running Win 8.1 that has neither of those programmes and have just used it to see if I could run MT4 via the RUTX50 and again it wouldn’t run. I then tethered my laptop to my mobile using mobile data and I got an instant connection. Repeated the process on my office PC (Win 10.1) and again MT4 worked. So that has definitely isolated this to a router issue.

  3. Tried pinging on PC and timed out. Pinged and the ping was successful. Not sure what this means but hopefully it will mean something to you guys.

Not sure if I can give you anything else that is helpful and look forward to any further thoughts.



Thank you for going through the suggested steps!
A few additional questions:

  • When you switch PDP type to IPv4, does the mobile interface obtain an address, or does it remain in the Down status?
    • If it does obtain an address, is it an IPv4 or IPv6 address?
  • Are you using AutoAPN?
    • If yes, could you try disabling it and configuring your APN manually according to the instructions provided by your carrier?
  • What ISP are you using?
  • Could you try replicating the test from your third step, but instead of use 2001:4860:4860::8888?

Best regards,

Hi Daumantas,

Thanks once again for coming back to me…

When using IPv4 the status goes down and stays down. II was using manual APN “everywhere” which is the default for the EE sim that I am using.

I was able to successfully ping the 2001: etc address that you suggested.

Any more thoughts?



Firstly thank you for all of your support. As you might imagine I have been ploughing through these forums until I am “dizzy”. However, I have now found the solution, no matter that it seemed to make no sense to me.

I have changed the IPv4 setting on my ethernet connection from seeking a random IP address to giving it a fixed IP address and specifying the default gateway and BINGO everything works instantly… Very relieved and a little intrigued as to why that should make a difference. If you can explain that to me I would greatly appreciate it.

But in closing, thanks for the support, it meant a great deal to me whilst I was wandering around in the wilderness,




I’m glad that you have been able to access the services you needed, however, the issue may still manifest itself on other LAN devices.
As for your first comment - you seem to be using the correct APN for EE, however, it’s interesting that you’re only receiving an IPv6 address. I would suggest contacting EE to make sure everything is configured correctly on their side.
As for static configuration, the only ideas I could think of are:

  • The DHCP server on the RUTX50 is not functioning properly;

  • You have a second DHCP server in your LAN (likely on accident);

    • To check this option, could you let me know if you have any additional networking devices in your LAN? (wireless routers, L2/L3 switches, etc.)

Best regards,

Thanks for coming back to me. I have a TPLink Power line adaptor connected to the router by RJ45 cable plus my own PC. Apart from these items everything else connects via WiFi. Despite the issues I have had the TPlink has worked throughout. I use it to connect my TV in the lounge to the network by RJ45 cable

Had a quick look at the router this morning:

Status> Network>Lan. Expected to see my PC under DHCP leases (set to infinite) but there were no entries.

Though I am now connected, my “workaround” makes no sense to me. Not sure there is an issue with EE as until the upgrades everything worked seamlessly and the Sim card is the same.

Any further thoughts\actions would be appreciated as I would very much like to improve my knowledge here and understand why I had to make changes simply because I updated the router. My theory in the past was always never update anything that is working seamlessly. LOL. Should have followed my instincts!!

Whoops, bit early for me, I now get the DHCP situation as I am using a fixed IP address. Sorry for that.


The only change which could have impacted your mobile connection, is that with the latest firmware, carriers that support dual stack connections will now establish IPv4 and IPv6 connections. Other than that there shouldn’t be any major differences.
As for your particular setup, it’s hard to say what could cause the issues here. But just to clarify - is everything functioning properly now? Or do you need additional assistance to get everything up and running?
If further assistance is needed, it might be better to organize a remote troubleshooting session to diagnose the issue further. Let me know if this is needed, and I will send you a form to fill out to get in touch with us privately.

Best regards,

Hi Daumantas,

Thanks for your response. Even though I am not convinced I have the perfect solution, everything is working and speeds have definitely improved with the upgrade. So I am happy enough and will see how things are going forward.

Thank you once again for all your help.

Have a great Easter break.



1 Like

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.