RUTX50 Modem Temperature

Temperature sensor on modem, can this be added to get status feature on SMS and email?

The reason the unit is used outdoors in IP67 enclosure,it would be good to monitor the modems temperature :thermometer:

What command do I need to use?

What command do I need to use?

https://wiki.teltonika-networks.com/view/RUTOS_gsmctl_Commands#Get_module_temperature
gsmctl -c

You can put together a script that periodically runs this command and when the value is high, it sends an alert by mail or SMS.

I use this device outside in an IP66 cabinet in hellish heat (up to 40°C in direct sunlight), the modem goes to a maximum of 68°C and has been working like that for the second summer without any problems with heavy data.

The maximum limit of this modem is 75°C

2 Likes

but, as far as I know you cannot shuwdown the RUTOS right ?
I now have a simple Bimetal temperature switch in the power cable.

Hello,

You can use several commands to get this value:

  1. Use the command: gsmctl -c as tirkiz already told.
  2. Alternatively, you can use the Ubus command: ubus call gsm.modem0 get_temperature
  3. Or, you can use the RUTOS API with the following command: api get /modems/status | jsonfilter -e '@["http_body"]["data"][0]["temperature"]'

More about API can be found here: https://developers.teltonika-networks.com/

Best regards,

Are there any integral self-protection mechanisms, either software and or hardware generated, for example, that prompts a graceful shutdown and or switches off the router anyway?

Sending a text and or an email prior to a controlled graceful shutdown generated by a self-protection mechanism such as too hot, too cold and perhaps high humidity could be a very useful addition. Admin would know there’s a problem and why a router switched itself off. Knowing why gives admin an opportunity to explore why and what can be done to prevent the issue happening again.

1 Like

Hello,

I’ve tried using gsmctl -c in the SMS utilities option ,get status option,and does not work?

Is a issue with text format?

Hi @Teknology,

The ‘gsmctl -c’ command should work. Perhaps your modem is disconnected? Do other gsmctl commands work on your device, or is it just the -c flag that has an issue? You can find more information about gsmctl commands and how to test them here: Gsmctl Commands.

Best regards,