RUTX50 Mesh Network - Configuration / traffic Issues

Hi, I have been struggling with this for a while and cannot work out how to resolve. I have a RUTX50 with mobile connection for internet that works well. I then purchased 2 x RUTX10 and followed your mesh network configuration guide. The issue I have is that turning on the RUTX10’s seem to cause traffic issues with slowness and network dropouts. If I switch off then connectivity is ok, I was trouble shooting Denon HEOS and it was clear that streaming failed with the RUTX10 on but when switched off it was better.

We are rural so have no interference with neighbours, all RUTX devices have the same network channel and have both 2.4 and 5ghz networks with respective mesh networks. I assume I have something setup wrong but started going down a rabbit hole with all devices on same channel could be causing interference? but then your guide states they should be.

So my question is where to look next, what issues could it be and should I explore a different config. I want to achieve 1 whole home wireless network (2.4 and 5ghz versions) with good speed in all rooms and was hoping to achieve this with mesh setup.

James

Hi there,

Thanks for reaching out.

There is a commonly known issue with mesh network setup that causes traffic issues and low speeds. This issue is being fixed within the new 7.8 firmware update of your RUTX device.

The update is planned to be released next week.

Best regards,
Tomas.

Thanks for the update Tomas, I see it has pushed out to this week now. Let me know if you need anything testing. I look forward to the update coming soon…

Hi Tomas, I have factory reset and am starting again. In the RUTX10 when I go to change Lan protocol its set at static and the only other option is none. In the videos it show DHCP for the mesh node - what settings do I need to select?
Thanks, James

Hello, James,

Your LAN interface should be set as static, that is fine. You can find your DHCP server settings by heading Network → DHCP on your device’s WebUI.

Also, I would offer you to check on a configuration example of Wireless mesh that can be found on our wiki page. Also, there is a configuration example of TAP devices, which is made on a newer firmware version, that might be relevant.

Best regards,

Tomas.

Hi Tomas, the issue is I cannot change the protocol of the node to dhcp (the last configuration step) but I have managed to do it via CLI using:

uci set network.lan.proto=‘dhcp’
uci commit network
/etc/init.d/network restart

I can now see the RUTX10 in the leases in the RUTX50 so it looks to be ok. Is there a bug somewhere that stops this appearing in the WebUI?