Rutx50 keeps rebooting

Dear community and Teltonika support,

I’ve been experiencing unexpected reboots of my RUTX50 and I would like to get to the bottom of them.
Please instruct me what indices to gather and how to get them!

  • Firmware version: RUTX_R_00.07.07.3
  • Firmware build date: 2024-06-18 12:31:57
  • Internal modem firmware version: RG501QEUAAR12A08M4G_04.200.04.200
  • Kernel version: 5.10.210

I power the router via PoE.

Thanks in advance!

Robert

Hello,

Have you configured the auto reboot feature before? Maybe that was the cause of this issue.

However I need troubleshoot file from you to check&investigate deeply. Since it contains private information, we’ll handle it on a separate platform. Instructions for accessing it have been sent to the email you registered for this forum. Required ticked ID would be 4 digit number of this active case.

Regards,
Caner

Hi Caner,

I have the auto-reboot set for 4 AM, but that is not the issue, ofc, but the reboot which happens either when a new WIFI client connects, or a larger stream/download is initiated… dunno, need more details as well as you do :slight_smile:

If reboot happens on some actions, most possibly RUTX50 lacks of power. Could you try to use original power supply and not the PoE?

Hi iBoucher,

Can’t do. Router is up on 15m mast and only connected with LAN cable.

I was after some diagnostics of power/voltage but couldn’t find any…

If you are using an Ethernet PoE switch to power an Active to Passive PoE converter, then the Switch port needs to be 802.3at, in order to deliver the 18W potential maximum power consumption of the RUTX50. Needless to say, your PoE Converter has to also be capable of delivering this output or more.

This is all assuming that the RUTX50 is being powered through its LAN Port 1. If so, I’d also be investigating how well the RJ45 connectors are attached to the cable. Time to ‘shimmy’ up that mast, and whilst you’re there, check the water-tightness of the RJ45/cable to the device and enclosure.

Also if in a marine environment, then give the SIM a thin coating of dielectric grease and spray or ‘paint’ something like ACF-50 onto the connectors of plugs and sockets, including the RJ45’s and anything else that may be affected by a saline environment. Treat your PoE converter to the same inspections and ACF-50. This should become an annual maintenance task.

For that distance of cable run (15m), I think we can discount the AWG size of your ethernet cable.

Hi Mike,

Cat 6 outdoors cable is connected on LAN1, enclosure is weather- and waterproof and the PoE converter (POE-INJ-1000-WT - Tycon Systems Inc) should be able to easily handle 18W as it’s rated at 60W (on paper). Even with that, my bet is still on the power source – that it with increased processing power needed for new client connection (?)
drops below required voltage/power and auto-reboots.

Nevertheless, I’m still waiting for instructions on how to get such details (e.g. voltage of the system) from system diagnostics first, before climbing the mast.

As for the standard, unfortunately, you have made a false claim, at least according to official RUTX50 Powering Options page (RUTX50 Powering Options - Teltonika Networks Wiki):

Thanks for trying to help and for your good hints.

Additional question regarding PoE:

If the tech specs of the router “ban” IEEE802.3af, 802.3at and 802.3bt standards:


and there is only one other standard: IEEE 802.3bu-2016 (at least according to Wiki: Power over Ethernet - Wikipedia), how come that one’s not listed as required (and user is left wondering which one to use when the router is “not compatible with” 3/4 of them)?

Hi Robert,
did you test an external power supply instead of POE to exclude POE problems?

Regards,
Chris

Hello,

I just received the troubleshoot file!

From your configuration it can be seen that you configured auto reboot schedule for each day.
But also there are some unexpected shutdowns but it is hard to find the cause for this issues, because after device is rebooted flash memory is erased and all the logs related it are basically gone.

Can you please try to power up the device with the power supply? And check if the issue is still there?

Kind Regards,
Caner

Hi Saran,

What I meant in my post was, if using an In-line Ethernet PoE Converter to power the RUTX50, and the PoE Converter was getting its power from an Ethernet Switch, then the switch does need to be 802.3at compliant - see picture below.

This is all a bit of a moot point in your case though because, from what I can tell, you are using a PoE Injector that is NOT powered from a switch, but an independent DC source.

What that is telling you is that LAN1 port used Passive PoE Mode B.

Mode B delivers power on pins 4 and 5 for +ve and pins 7 and 8 for -ve

Mode B is the only standard, to my knowledge, that the RUTX50 uses on LAN1

Yes. Before mounting it externally, I tested it at home with original PSU. Not sure now, but I think I saw unexpected reboots also then…

Ah, I see now – standard is relevant only if device is powered from a switch, not from a passive PoE injector (like in my case). Thanks for clarifying.

Well, there is surely a “panic” trigger (too low voltage, too high temp., etc.) that forces the device to reboot, so I would expect a core dump etc. was persisted before the reboot procedure was carried on with. Just a layman’s view, ofc.

Also, I asked several times (mail, posts), but didn’t get a reply yet: is there a voltage/power metric recorded anywhere in the logs?

The voltage in the system (which I have detailed measurement off) fluctuates between 12.5 and 13.9V, but never goes below. Highest power drain (on the sailboat) is the refrigerator which draws 5A and when it kicks in, the voltage drops only 0.25V (to 13.75V), so that shouldn’t be an issue…

As I already answered you in the email, sorry, but I can’t do that (in near future).
Also, as I mention in a previous post – I kind of remember I had similar issues also when I was using the original PSU (at home).

Gets a +1 vote from me

Hello,

Unfortunately we don’t have this feature yet, however our developers already aware of the request. It may be added in the future!

As I already mentioned I can not see the root/cause from the troubleshoot file. However if you save logs in flash memory, I may find the change to understand the issue from troubleshoot file!


Can you please do the needful configuration chance and send me the troubleshoot file after device’s next reboot?

Regards,
Caner

Sure, Caner. Will do the change and get back to you as soon as I have the unexpected event caught “on tape”.

Hello Saran,

We’ve contacted to you via hubspot for private solution.

Please check your inbox!

Kind Regards,
Caner

Hi,

I’ve flashed the unofficial/test FW Caner provided me and sent him 2 troubleshoot logs.

After that I have flashed the new official FW (RUTX_R_00.07.08, that was FOTA-broadcast) and I haven’t had an unexpected reboot yet (as it has been just few hours of usage), nevertheless I’m still experiencing network disconnects e.g. when a new device (laptop in this case) is connected to WiFi:

I can also simulate that mobile disconnect consistently when I put a load on the network (e.g. start few streaming services [Netflix etc.] and do a speedtest.net test in parallel).

It’s quite ridiculous to have a network disconnect just based on higher bandwidth usage, but it’s also possible the reason could be on the provider side (even though I haven’t had such issues on my mobile phone). I just hope something be deduced from the logs I sent (also containing those network disconnects) so this can be fixed.