RutX50 hangs and gets unresponsive

Since a few days my RutX50 has stopped working from time to time. It gets unresponsive and I can’t access the GUI. I have tried both LAN and Wifi, the router is hanging. I have had to do factory reset a few times and doa clean install. Once it started working without factory reset after unplugging power for 5 minutes.
The router has been reliable for the past months but as I wrote this started a few days ago. I’m running latest firmware.

This is not OK, thinking this must be hardware related since it’s been running faultless for a few months until now. I’m returning the router if there is no fix for this.

No reply here?

I can add to this topic that today when the rutx50 got unresponsive I unplugged it for 10-15 seconds and plugged it in again it did not start. I then unplugged it for 10 minutes approx and after that it started up again, really strange…

Teltonika is as unresponsive as my router, still no reply here… I have started the return of the router now but would have given it a try if I got a response here.

Dear Orre,
I apologise for the late reply and your inconvenience.
If it still helps could you cross check the below.

  1. The screenshot you have sent shows that its running FW 7.05, but the latest FW is 7.06 (Release 20/12/2023)
  2. Did you notice other factors like temperature etc ?
  3. Can you also please explain the working topology and the conditions that the router is subjected to ?

Please Note : You can also get very quick support via your local sales manager, and they can also help with RMA (If required)
Clive Pinto

Hello thanks for getting back.

My topic was created before 20/12 release. I have now updated and will test more. Was there a bug fix for hanging routers?

RUT-Router is connected LAN to LAN (unify switch) and then LAN to LAN to a unify dream router/wLC. Rut is no dhcp. Unify router/WLC is and handling clients on my local network. No specific routing.


This topic was automatically closed after 15 days. New replies are no longer allowed.

There has been numerous patches and upgrades with the new firmware - You can find the logs here.
We will wait for your findings before proceeding further.