RUTX50, FireTv 4K, Xbox One updates not working anymore

As the proprietor of the TRB500, I recently underwent a router replacement due to deficiencies in SQM/QoS. Following the setup of the new router this week, I have successfully established connectivity for all devices, except for two— the Amazon FireTV 4K, and Xbox One.

The Amazon FireTV 4K is on its own port, LAN1 port, while Xbox One is connected on LAN2 port.

Unfortunately, I am currently encountering an obstruction hindering the Amazon FireTV 4K from accessing the internet. While the device maintains a functional internet connection (Amazon Silk browser works fine), attempts to install new applications result in non-responsiveness and a subsequent server error. Same goes for Xbox One, it can access the internet trough browser, but cannot access or update anything else.

It is noteworthy that the aforementioned functionalities operated seamlessly on the previous TRB500 configuration. I am reaching out for your expertise in diagnosing and rectifying this matter to ensure seamless operations across all devices.

Note also that when i am connecting FireTv 4K and Xbox One via WiFi of my phones personal hotspot, everything works as it is intended to.

Current firmware on the router:
|Firmware version|RUTX_R_00.07.05.4|
|Firmware build date|2023-11-07 14:54:54|
|Internal modem firmware version|RG501QEUAAR12A08M4G_04.200.04.200|
|Kernel version|5.10.188|

Please advise! Thanks!


It seems that the issue can be related to MTU. Please, navigate to Network → WAN → Edit mob1s1a1 → Advanced settings and try setting a custom MTU. Values to try are 1460, 1360, 1260.

If the above does not help, please navigate to Network → Firewall → General settings and try disabling 'software flow offloading’.

Let me know about the results.

Kind Regards,

That doesn’t do the trick, it is still the same. What else could be wrong?


Hard to say what exactly is causing the issue. The issue can be related to DNS as well. Could you please try navigating to Network → WAN → Edit mob1s1a1 interface → Advanced settings and try adding custom DNS server? Add and as your custom DNS servers and let me know how it goes.

Kind Regards,

That did a job it seams. But found out just now that something is blocking javascript now, as i cant see any ads, any captachs and so on? What could be a problem? If i share personal hotspot, JavaScript is loaded properly?

Note that i am not sure if that stoped working now, or was that the case before also.

2nd update. Now i also noticed SmartIPTV app of FireTv isn’t loading playlist, nor loading first page of Amazon home page??

Which settings could do that now, don’t follow as I didn’t had those issues with TRB500??


Are other devices/applications working fine?

Have you tried using a different SIM card? Perhaps the one from your phone or maybe from a different operator?

Could you try setting up a hotspot on your telephone and then connecting RUTX50 to it in client mode? I.e.:

FireTV – cable → RUTX50 – WiFi client → Telephone → Internet

For this configuration, simply navigate to Network → Wireless → press SCAN, choose you WiFi, enter its password and leave all other settings as defaults. Wiki here.

Is everything working properly this way? This would help to see if the issue is related to mobile connectivity.

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.