RUTX50 channel analysis fails

On my RUTX50 (07.07.01) it is not possible to do a Wireless Channel Analysis. Perform scan ends with the message ”Failed to scan devices”. What could be the problem? Best regards,

1 Like

Just tested on one of my RUTX50 with 07.07.1 and it works fine.
So it is not a firmware issue.

All radios are turned on?
Can you rest your box to factory defaults and try again?

With on only 2.4GHz running (RUTX50 / 07.07.1) I have no isues with Channel Analysis.

Enabling 5GHz also had no Channel Analysis issues but then had no other 5GHz in the network. Enabling a separate 5GHz AP the RUTX50 could not detect that so I changed the default Channel (36/5180MHz) to Auto and Width from 80MHZ to 40 MHz and duplicated exactly “X Failed to scan devices” on both 2.4 & 5?

Changed 5GHz back to the default values, both 2.4 & 5 then scanned ok, changed the 5GHz default values again and both 2.4 & 5 scanned ok?

Took a while but was finally was able to reproduce “X Failed to scan” on both 2.4 & 5 and appears to be a combination of the 5GHz Channel set to AUTO and Bandwidth set to 20 or 40 but there is certainly some inconsistency and maybe dependent on the order of changes and if both changed (Save & Apply) together? Can’t quite nail it but there is something in there with 5GHz

Thank You for advices. All radios are on and channel / width settings make no difference.

I made a full factory reset and after that the channel analysis functioned for a while but then stopped working. Now it seems that if there is a Wi-fi WAN the channel analysis function fails. When I deleted the wireless Wifi1 WAN the Wi-fi analysis started to work again and stopped once moore, Still confused. Best regards,

This could be the solution to my problem. If the ACS (automatik channel selection) for 5 GHz has chosen a DFS channel, scanning channels will not function. One can prevent DFS channels from being selected here / Network / Wireless / Radio / Wi-Fi 5 GHz settings / Advanced settings / ACS exclude DFS / set radio button to ON.

That makes sense :+1:
Not so sure though if 5 GHz Auto DFS settings would affect 2.4 GHz scanning capabilities in general…?
In my opinion 2.4 GHz scanning should work independently from 5 GHz settings.

With 5G set to AUTO have also seen reference to DFS but unable to duplicate that today.

Today Enabled 5G both 2.4 & 5 scanned ok, changed 5G to AUTO/20 both 2.4 & 5G scans failed, checked some other values both scanned ok, set 5G back to AUTO/20 both scanned ok. Could not duplicate scan failing, came back 20 minutes later, set AUTO/20 and both scans failed, just don’t see any consistency?

Likewise, I’m unable to with my RUTXR1:

Can you upgrade your firmware to version 07.07.1 and try again?

RUTXR1 Firmware Downloads - Teltonika Networks Wiki

1 Like

@TeWe, I’ve just upgraded to that version, but it didn’t remediate the problem:

Would you mind taking a backup (just in case so that you can restore if needed) and reset your XR1 to factory defaults?
Working then?

1 Like

@TeWe, would such a backup be trivial to restore in its entirety?

I think it’s quite nicely described here:

Missing Network/Wireless page in firmware RUT9_R_00.07.06 - #9 by Mahmoud-Basiouny

1 Like

Before I do so, I’d like to note that I have 2 RUTXR1s, configured similarly, and both exhibit the behaviour regardless of OS version.

@TeWe, I’ve performed as described:

  1. Generating a new configuration file

    Go to the device WebUI > System > Maintenance > Backup > Backup configuration page and click the Download button.

  2. It now works, even after manually applying the changes. Considering that my other RUTXR1 still can’t, I can only attribute it being able to now to having reset it. Thanks.

1 Like

Very nice to hear it works now :slight_smile:
You’ve been curious about backup/restoring, but I guess it was a nice exercise/learning curve now.

1 Like

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.