Rutx50 Band jumping with 5G enabled

I have purchased the Rutx50 and just want to report this issue and see if this is a known problem? I have seen that others have had issues with 5G

Using Telia in Sweden. In certain situations when I have Network Type set to Auto (Using 5G) the mobile bands go crazy and jumps between all possible bands and the router beomes unusable with speed <1Mbit/s and very high latency.

The router switches bands every second switching between 4G 4G+ 5G

If I set it to only use 4G /LTE) everything works.
It locks to three bands and stays there with 100+ Mbit/s

LTE B3 / LTE B3 / LTE B7

I have troubleshoot files available at request.

On latest firmware:

1 Like


It’s hard to say what could be causing the issue in this particular case, however, usually outside factors such as:

  • Cell tower load;
  • Weather conditions;
  • Maintenance / power-saving measures by the operator;

Could be playing a role here. If you feel comfortable using the command line, I’d recommend trying to lock the router to a particular cell. We’ve had a similar question here: RUTX50 - Locking 5G-NSA CA bands manually - #4 by Daumantas
Basically, cell lock will allow you to use a single cell as the primary (let’s say B3), while the secondary bands will also be utilized (band lock will not allow this). Once you have a stable connection, run the command described in this step and find out which PCC (primary) cell is providing the connection. Then lock to it as described in the linked forum post.
Let me know if this helps!

Best regards,

Thanks for your prompt reply, I tried to utilize band lock and it worked better but since 4G is sufficient I used that.

You should not have to bother about these things.
Other products handled the same situation without problem so I think you need to continue troubleshooting and upgrading your firmware’s.


This topic was automatically closed after 15 days. New replies are no longer allowed.