RUTX50 and EE incompatibility

I have read several threads on this subject where the router with and EE sim and smarty Sim show’s the network as 3G (WCDMA) and connections are rejected.

I have had a RUTX for a yr now and my EE sim worked perfectly fine last year. I believe the problem to be related to EE 3G turn off !

The symptoms for me and the reason EE blamed the router were that the SIM worked perfectly fine in the phone, in my case I had another EE sim and vodaphone sim that worked. but that was not enough to convince EE 2nd line who really weren’t interested that the issues was phone number related, the SIM i had replaced.

After 10.5 hours on the phone and visiting EE store i finally got it working, and i think this is a teletonika issue or at least they can fix it. I set the SIM to 4g only in the config and it worked fine. now strangely when i switch it back to 3g,4g,5g it continued to work even after several reboots.

I hope that works for others and would be interest to know why the router seemed to stick on 3g handshaking connect to a mast but no connection. I believe phones work, and other routers with EE because they try highest speeds first, how does Teletonika work ? why do they seem to try 3G (WCDMA) first and get stuck

This topic was automatically closed after 15 days. New replies are no longer allowed.