RUTX14 WiFi Issue

I reached out last month for help with an RUT240. The link to the issue was:

Unfortunately the forum seems to be down. Has that issue been simply dropped, or can I expect follow-up?

The issue never got resolved. So I purchased what I hoped would solve the issue, an RUTX14. The RUTX14 does maintain the WAN connection better than the RUT240, so that’s the good news. The bad news is that I haven’t been able to get the WiFi to work very well, not well enough for my needs. I should probably describe a bit more what I’m trying to do.

The network is on my boat. The radar I purchased connects via ethernet, 100Base-T, which is plugged into a RUTX14 LAN port. I’m using navigation software on my Mac to display the radar overlay, with a WiFi connection to the RUTX14. This setup did not work well with the RUT240. What I found was that if I connect the Mac by ethernet it worked much better. That solved the display problem but required that my connection to the Mac be much more complicated, since the MacBook Air only has 2 USB-C ports. I needed to use a separate USB-C hub with ethernet. I’m really wanting to avoid that.

When trying to get the RUT240 issue understood, I purchased a cheap Netgear WiFi-enabled home router. What I discovered when using the Netgear WiFi was that the radar overlay display worked just fine. I thought that was a bit strange that an expensive Teltonika router WiFi wouldn’t work as well as the cheap Netgear WiFi, but I didn’t try to get to the bottom of that. When I made the decision to buy the RUTX14 I assumed my WiFi issues would be resolved, especially if I used the external antennas which can be “seen” directly by the Mac, 4 feet away.

Alas, using the RUTX14 and WiFi, the radar overlay display barely functions—at least 50% of the data is lost, and the connection breaks often. It seems to be worse on 5 than 2.4. I’ve re-installed the Netgear router and it all works fine on WiFi. As you can imagine, this is really disappointing and surprising, given that there’s a 10X price difference and that my only choice for antennas on the Netgear are the short built-in antennas and the router is inside a cabinet.

Can you help me understand what could be going on with the RUTX14, and how to fix it?


Apologies for the delayed response.
Perhaps you could post screenshots of your WiFi interface, it’s advanced and security settings, as well as status with the sensitive information blurred out? This might help identify the issue on hand. Some things that can be tried:

  • Use WPA2-PSK encryption. While it is theoretically less secure, it is supported much better across different devices;
  • Make sure you are on the latest firmware;
  • Try using different cyphers;
  • Try using 40MHz channel width on 5GHz;
  • Make sure you are using a non-DFS channel (36 is a good choice for 5GHz);

I will also ask you to open Terminal on your Mac and run the command ping (or use a different IP address if it was changed on the RUTX14). Run it for around 20 seconds and post the output in the next message.

Best regards,

I am finally able to re-connect the RUTX14 and try your suggestions. Unfortunately I have not seen much improvement.

I have been using WPA2-PSK all along.
I am using FW RUTX_R_00.07.04.3, which seems to be the latest.
I’ve tried both 40MHz and 20MHz on 5GHz. It doesn’t seem to make a significant difference.
I’ve been using channel 36, but I tried other channels as well.

This is what the radar looks like when data is lost.

Here’s a screenshot of the Terminal ping:


What’s mysterious to me is that no other internet/web or network traffic seems to be affected. I can have Zoom sessions and watch video normally. The radar overlay is the only thing that is having an issue.

When I switch back to the Netgear router I’ll send a screenshot of what the radar overlay should look like.


Here’s a screenshot of the radar overlay with the Netgear router on WiFi

Here’s a screenshot of a Terminal ping:


I’d really like to figure out why the RUTX14 WiFi is so much worse than the cheap Netgear router WiFi. Are you out of ideas, or is anybody looking into this?


Apologies for a delay.

It is difficult to pinpoint the exact cause of the issue. Did you experiment with different WiFi settings?

However, you mentioned that:

  1. The connection via cable is fine, but the issue arises with WiFi.
  2. With the Netgear router, the WiFi connection is better.
  3. The RUTX14 router has external WiFi antennas, unlike the Netgear router.
  4. The setup is on a boat.
  5. The 2.4 GHz band performs better than the 5GHz band. However, you mentioned that the device is close to the computer, so theoretically 5Ghz should perform better at close distances.

Considering these factors, signal interference can be a potential issue. The RUTX14’s stronger signal, produced by its two external omnidirectional WiFi antennas, may be leading to increased interference in an environment with many reflective surfaces, such as metal and water (boat). This is particularly likely given the better performance of the 2.4GHz band, which typically has better penetration and reflection characteristics than 5GHz.

Could you please provide more inforamtion about the environment where the router is located?

A few things to try:

  1. Try placing the device in a different area of the boat for testing purposes.
  2. If the signal strength is too high, it might be causing additional interference. Reducing the transmission power could potentially help with this.
  3. If possible, reduce the number of WiFi clients connected to the router for testing purposes. Additionally, you can disable the 5GHz band completely if it isn’t necessary. If two WiFi clients are required, you could try connecting one client to the 2.4GHz band and the other to the 5GHz band.
  4. You could try using just one WiFi antenna, although be aware that this may worsen the issue, as it could affect MIMO, which generally helps in dealing with interference.

Let me know about the results.

Kind Regards,