RUTX14 connection issue with carrier aggregation

Hello. I am currently using a RUTX14 with firmware RUTX_R_00.07.06.10 (newest to date)

Currently I’m facing a problem in which the router will lose connection if carrier aggregation drop. The router would connect to 3 bands CA in my case, which is B1+B3+B3. However, if the connection drop down to either B3+B3 or B1/3 only, the router would lose internet connectivity until I reboot it or hit the Restart connection button.

I need help to rectify this issue. In my area I would very frequently get dropped down to double or single aggregation, and having to restart the connection everytime is such a pain. Why can’t the router just provide internet at a lower speed but rather lose connectivity completely?

Thanks in advance!


You can improve your device’s connection by restricting it to specific LTE bands that are known to work well. To do this, follow these steps:

  1. Go to Network → Mobile → General settings.
  2. Set “Band Selection” to “Manual.”
  3. Choose your desired LTE bands from the available options.

Feel free to experiment with different bands to find the ones that work best for your device.

Best regards,


Thank you for your reply.

But first of all, where I live the signal is very unstable, there is no one-band-fits-all solution, the 4G would jump around between band 1&3. So that’s why I want to stay on multiple bands setting always, so the router could do the work for me and go back and forth between each available bands, and then aggregate multiple of them if present.

Second, what you are suggesting from my understanding is that I should just bear with this issue and select one band only to prevent being disconnected due to CA not working properly. Why do I have to make compromise for a device of this caliber (in terms of cost) that does not work properly?

I want proper solution to fix this, not workaround.

Hi there,

How’s your Signal strength? Is it in the “OK” or “Good” zones, and how often/much do they fluctuate? Have you attempted to relocate the router or adjust the antennas? Just to remind you signal quality has a major impact on the speed and readability of the connection.

If possible, could you take a screenshot of the Status → Network → Mobile page?

Best regards,


My signal range mostly go from fair, and to poor very occasionally. I have tried all possible locations in my house and it is sitting in the most advantageous one, and antennas don’t really do much however I turn them.
The signal would switch between band 1 and 3 around 3-4 times a day, every time I would have to do a reboot since restarting connection doesn’t help anymore.
Moreover, since my last reply a new issue surfaced. The router keeps blinking between the 3G and 4G LED indicators, no LED is showing for the Sim or connection strength, and it says not connected in the mobile status page.
Now I have to fiddle with the band selection setting and try between B1&3 to see which works, leaving it on Auto doesn’t do anything, just keeps failing to connect. Even when it does it still says disconnected in the Status page, and LED are blinking constantly as I mentioned earlier. This is very frustrating and a bad first time impression with Teltonika router for me.

Here are some screenshots for your information. The first one is on Auto mode, the router failed to establish a connection and cycled between 3G and 4G LED indefinitely.

Second one is after I went and set Manual band selection to Band 1 exclusively. Internet was restored for some time then is lost again until I switched to B3. 3G and 4G indicators were still taking turns blinking.

If I tried to set B1+B3 then it would show the same thing as screenshot #1, and no internet connection is made until I manually switch to a single band that was working at that time. Sometimes I would get both B1+B3 but after a while connection would drop, and the status page would show as screenshot #2, either B1 or B3 connected but internet was not accessible, as I stated in my original post.


The RSRP and SINR indicators show very low numbers.

2024-04-10-14-50-11-RUTX14 connection issue with carrier aggregation - Teltonika Networks - Teltonik

RSRP measures how strong the signal is from the base station of the cell you’re connected to. This is the main problem - the signal is very weak.

To improve this, you’ll probably need stronger antennas. Simply changing bands won’t help much because the signal is inherently weak and there’s a lot of unwanted noise (indicated by the low SINR value).

Best regards,

You are missing the point. What I’m trying to say is that while the signal is bad, it works if I just manually switch over to another band. Meanwhile the router either on auto setting or multiple custom bands selected would not be able to make an internet connection.


I still believe it might be weak signal issues, especially since it keeps disconnecting on B1 and B3. Have you tried moving the router to another location where the signal is better or closer to the cell tower? Doing so would help clarify whether it’s a signal issue or an issue with the router itself.

Best regards,


I still haven’t been able to rectify this issue, but I’m trying cell tower locking to see if it fixes connection drops. I’ currently following this guide:
And using the section for Quectel modem since that’s what on mine. However there is an issue, when I enter the cell lock command:
gsmctl -A ‘AT+QNWLOCK=“common/lte”,2,,’
The result returned as error. See screenshot below:

I’m connecting to the CLI interface through a ssh client. Please help

This topic was automatically closed after 15 days. New replies are no longer allowed.