RUTX12 Modem Update Issue

After a few days fumbling around with this issue, I turn to this community.

I’ve tried several thing to get the “Primary Modem” updated, but unfortunately with no success…

I first tried to update it through the GUI, with following error messages:

After that, I went into the CLI by SSH to see if I can do something over there:

Unfortunately, also no update progress. So I downloaded the .zip file where it points to, and that download went just fine.

So I tried to upload the .zip through the GUI with this as result:

Could it be, that in the backend, a wrongly firmware is applied, and that therefor the upgrade can’t go through?

Thanks in advance for any reply.

Looks like this is either a very difficult situation, or a dead “forum”…


It seems that the main issue might be modems being unreachable. If modems are unreachable, connections can’t be made, and upgrades can’t be performed. Can you establish a mobile connection using either of those modems?

Best regards,

Thanks for your reply!

I inserted a working SIM, but the primary isn’t recognizing it in any way… I will try a different SIM but I have the feeling that the modem could be broken.

Is there another way to check it, through ssh or something?

Thanks in advance!

In addition, both modems have a SIM installed:
Screenshot 1

It looks like the primary modem doesn’t respond at all anymore…


The modem may be broken. To check this, you can try factory resetting the device (make sure to take a backup if any important configuration settings are present ) and then check again. If the issue persists, it’s likely that the modem has failed and needs to be replaced. In that case, you should contact your reseller or Teltonika if you bought directly from us, and we’ll initiate the RMA (Return Merchandise Authorization) process.

Additionally, the device may not connect with a modem on startup in some random cases. You can try restarting your device a few times to check if this might be the case.

Best regards,

Tried indeed all the things you mentioned, back to factory, bone stock and still the unit won’t do its job.

The unit became also very unstable, so I will attend my reseller for the RMA.

Thanks, you can close this topic if you like.