RUTx11 WebUI taking too long to load

After an update some months ago the WebUI takes ages to load. I’ve narrowed down the problem to be anything modem-status related (e.g. doing a bulk api request that requests /api/interfaces/status or /api/modems/status).

The main status page times out after waiting for 1 minute for the bulk operation to complete, any other pages that need modem-related data time out at around 30s

I’m running:

    Firmware version: RUTX_R_00.07.07.1
    Firmware build date: 2024-04-30 12:58:39
    Internal modem firmware version: EG06ELAR04A20M4G
    Kernel version: 5.10.210
root@modem:~# mnf_info -s

and it’s currently the latest firmware

I tried ubus call mdcollect clean_db '{"iface_name": "mob1s1a1"}' but I get Command failed: Request timed out so I stopped mdcollectd and removed /var/mdcollectd*

I’m not interested into a factory reset. I paid good money to have a good reliable system with advanced features that took me a lot of time to set up and use

Have same trouble - GUI on RUTX11 take long time to load.
Moreover, some pages displays incorrect status for example when I first time opens Network / WAN (after long time await) i see that WAN is DOWN but after page refresh (long time await) - status changed to UP. Same occured at LAN etc.

Just for clarification - did you guys also try a different browser and/or deleted the browser cache and/or tried with a new InPrivate window within your browser?
Everywhere the same issue?

@astf yeap, I have the same problems as well

@TeWe yes, tried firefox, firefox private, chromium, chrome (all linux) and safari on iOS. I was also able to find the problematic request and reproduce it with curl (ruling out any browser-related problems):

curl -H "Content-Type: application/json" -H "Authorization: Bearer <token>" https://router.local/api/bulk -X POST --data '{"data": [{"endpoint": "/api/interfaces/status", "method":"GET"}]}' (this isn’t the only problematic endpoint, any endpoint that fetches the modem’s status times out or takes about a minute)

Unfortunately I wasn’t able to decompile the lua bytecode and there’s no strace package available so I’m not able to dig any deeper (without substantial effort that is)

httpS problem?

Long wait for web interface response - #12 by jow - Installing and Using OpenWrt - OpenWrt Forum

nope, same behavior with plaintext http

Okay then it looks like you need to provide support files to Teltonika so that they can investigate further.
@Marijus @Marija


Thank you for bringing this to our attention. Our R&D team is already aware of the issue and is actively working on it. A fix should be included in the next major firmware release.

Kind regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.