RUTX11 - Use internet from wifi otherwise from sim card

I have a RUTX11 with firmware version RUTX_R_00.07.04.5 that I want to configure in a specific way:

  • Expose an access point with a given name say “my_rutx11” so that peripherals can connect to the router wifi.
  • By default, I want the router to obtain the internet from a wifi network. If the wifi is not available, then obtain the access to internet from a sim card. Both ways to obtain internet should not change the name of the exposed wifi access point.
    Is it possible to configure the router to have this setup and how? As of now it only obtains the internet from a sim card.

Thanks in advance!


It is always recommended to use the latest firmware versions on our devices. In your case, the latest firmware version is RUTX_R_00.07.07.1. As a first step, I suggest you upgrade the device.

You can change the access point name via the WebUI by navigating to Network → Wireless → SSIDs and pressing ‘Edit’ button. More information can be found here.

To obtain internet from a WiFi network, navigate to Network → Wireless → SSIDs and press ‘Scan 2.4/5GHz’. Select the network you want to connect to and connect to it. Detailed instructions can be found here.

Our devices come equipped with a failover function designed to serve as a backup for your primary WAN connection in the event of a failure. Through the WebUI, you can configure failover settings according to your preferences. When failover is enabled, our devices continually check the internet connection by pinging a specified server (default is and If the primary interface (WiFi) experiences a failure (no response from the server while pinging), the secondary interface (Mobile) is automatically activated. Once the primary interface recovers (starts receiving pings again), the system reverts to using it as the main connection.
More information about failover can be found on our wiki page.

Please let me know if you have any more questions regarding this topic!

Best Regards,

Thanks a lot for the quick response.

I remember having an issue when updating to the latest firmware. The LED signaling stopped working and there were no lights. That is why I downgraded to the version I specified in the issue.

I am not sure how to have a Wireless entry that is configured as an Access Point while at the same time have a Wireless entry that acts as a client (after scanning and connecting to a WiFi network). When I have both entries enabled, I stop seeing the access point wifi from my computer settings.



  • Just to clarify, have you upgraded to the RUTX_R_00.07.07.1 firmware, or did you attempt to upgrade to a different firmware version? (Because there are no known issues regarding LEDs with RUTX_R_00.07.07.1)

  • Apart from the LED issue, were there any other issues with the device, or did everything else work properly?

Regarding the wireless setup, I’ve conducted a test:

  1. I created an SSID named ‘RUT_AP’ in Access Point mode.

  2. I scanned for wireless networks and connected to another device’s WiFi named TEST, setting that SSID mode to ‘Client’.

3.Now, my RUT device has internet access via WiFi, and it’s also broadcasting a different SSID acting as an access point. I can confirm this by checking available WiFi networks in my phone settings.

Could you please double-check if you’ve completed all the steps correctly and try setting up the connection again?

If everything has been done correctly, the issue might be related to the firmware. I highly recommend upgrading your RUTX11 firmware, and please let me know if you encounter any further issues!

Best Regards,

Thanks for the detailed answer. The firmware update works fine and there are no issues with led displays. I have followed the steps and got it working!

I have one more question. What happens if you have 2 active wan interfaces at the same time that provide access to internet: one from a wireless Client and another from the SIM card. And you have not specified any failover. The router will choose randomly or what is the logic? Thanks!


I’m glad to hear that the issue has been resolved!

Regarding WAN interfaces, in the WebUI, under Network > WAN, you can see that interfaces are listed in sequence, each with its own number. For example, in the screenshot below, you’ll notice that “mob1s1a1” is listed as #1, indicating that it’s the primary WAN interface, and the router obtains internet connectivity from it. The subsequent interfaces, such as the wired WAN, are listed accordingly.

If you’d like to change the sequence, you can simply drag the interfaces up or down to reorder them as needed.

I hope this helps clarify things!

Best regards,

Okay, makes sense, thanks for the clarification! Your comments have been really helpful, I appreciate it. You can close the issue now.

I’m happy it helped!

Please don’t hesitate to ask on the forum if you have any more questions or concerns.

Best regards,


After testing it a bit further I have noticed that when the client wireless SSID is “Scanning”, the Access Point wireless network is not available and other devices can’t find it. Having the SIM card WAN configure with more priority than the wireless Client does not solve it. Even turning off the Client wireless wan interface does not help. Only thing that works is setting to Off the CLient Wireless SSID.

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.