RUTx11 - USB stick SMB fileshare config help

I have an IP camera connected to my RUT X11 on LAN. The IP camera can be configured to write files to an SMB Network Share, and the RUT X11 has Samba to configure a USB storage device as SMB Network Storage. Should be easy…
Unfortunately, the Web UI doesn’t match the Wiki page for USB Tools. Interfaces is missing, among other differences.

What’s the correct way to configure this? Even with no users / pw / security, I can’t get the camera to see the network drive. I suspect it’s an issue with Interfaces, so I modified the “template” (which I believe edits samba.conf) to lo eth0 but that hasn’t worked.

I can find the USB stick at /mnt/sda1 via the CLI, so the gap must be purely in the samba configuration. Help?
Perhaps firewall config issue? IP Camera has a dedicated port, with all accept+receive+forwarding set to enable from LAN to both WAN and Tailscale. However I don’t think that should effect LAN IP address calls, or SMB connections.

On the Axis camera side, I have attempted all combinations of hostname / IP address / share name to match the config on the RUT, with no success.

Welcome to Teltonika Networks Community !

Samba share works in the FW 7.6 without any issues. For a better troubleshoot can you try the below.

  1. Plug USB flash drive to USB port and format it via the WebUI.
  2. Refresh page Services > USB tools > Network Shares > Mounted file system. You should see mounted file system.
  3. Navigate to Services > USB tools > Network Shares > Samba user, create a new user by entering name, password and clicking “Add”.
  4. Enable Samba and add shared directories on menu Services > USB tools > Network Shares > Samba. “Save” configuration.
  5. Add the user in the “Allowed users”
  6. If you did the steps in the right way, you should be able to access shared files from your PC. On Windows OS do Start > RUN, enter [\](file:// Enter proper credentials and you will be able to access your USB flash drive files.

    Once it works on your PC then we can try it with the camera.
    Clive Pinto

This topic was automatically closed after 15 days. New replies are no longer allowed.