RUTX11 SDK Password & Default IP

I know the SDK isn’t officially supported by Teltonika. But tossing this out to see if anyone else has the same issue and has found a fix.

I’m using the SDK to build in a few modules and change a couple of default settings. Specifically the default admin password and default IP.

I’m editing the password in both places in ‘/RUTX_R_GPL_00.07.06/package/base-files/files/lib/preinit/84_set_password’ as the docs mention. The package compiles without error. However, when loading the image onto a RUTX11, the device still requires the randomly generated password from the label for admin login. I’ve also set the setting to disable the initial password change. But it’s not making any difference when compiling.

Same thing with the default IP. I’m setting the default IP using menuconfig as the docs state, it saves without error, but isn’t taking effect when compiling.

It’s acting as if the config files the SDK says to edit are being ignored when compiling.

Anyone run into this and resolved it?

Hello,

Yes, just put your modified files in “files/” not “packages/…” for example “files/etc/shadow” to change the password.
Regards,

I’ve tried this. I’ve put the network config file in package/base-files/files/etc/config/. Recompiled, it still compiles with the standard network config file that does not contain my settings. I’ve also tried putting this at the root directly. Still the same default IP settings. Somewhere I’m missing a location where the correct IP information is being set by the firmware.

Hmm no, the directory should be just files/etc/config.
From the base of the SDK:

mkdir -p files/etc/config
cp xxx/network files/etc/config

All signs point to that being the solution. But it does not want to compile those network settings. Still comes out with the default. Using SDK for 7.06.6 as well. Still digging in on this. Has to be a configuration somewhere in this code that is setting this stuff.

I have a default IP changed as well as APN’s set on the mobile interfaces. I set this with a config file, but want to set it as part of the firmware. Specifically the default IP. When compiling and installing on a RUTX11, the first thing I check is the network config file and it is always default. Completely ignoring my configs.

~/RUTX_FW/rutos-ipq40xx-rutx-gpl/files/etc/config$ ls ~/RUTX_FW/rutos-ipq40xx-rutx-gpl/files/etc/config/network
/home/user/RUTX_FW/rutos-ipq40xx-rutx-gpl/files/etc/config/network

And what do you have in this files/etc/config/network ?
In mine:

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.19.1'

gives the expected IP address for br-lan.

Nothing specifically different. Just a slightly modified version of Teltonika’s file. Only ip address, APN and DNS changed.

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option metric '1'
	option ip6assign '60'
	option _area_type 'lan'
	option igmp_snooping '0'
	option ipaddr '172.16.15.1'
	option delegate '1'
	option force_link '1'
	option area_type 'lan'

config interface 'mob1s1a1'
	option proto 'wwan'
	option modem '3-1'
	option metric '4'
	option sim '1'
	option dhcpv6 '0'
	option pdptype 'ip'
	option method 'nat'
	option auth 'none'
	option pdp '1'
	option _area_type 'wan'
	option auto_apn '0'
	option apn 'custom.apn2'
	option delegate '1'
	option force_link '0'
	list dns '8.8.8.8'
	list dns '1.1.1.1'
	option peerdns '0'
	option area_type 'wan'

config interface 'mob1s2a1'
	option proto 'wwan'
	option modem '3-1'
	option metric '5'
	option sim '2'
	option dhcpv6 '0'
	option pdptype 'ip'
	option method 'nat'
	option auth 'none'
	option _area_type 'wan'
	option auto_apn '0'
	option delegate '1'
	option force_link '0'
	list dns '8.8.8.8'
	list dns '1.1.1.1'
	option peerdns '0'
	option force_apn '-1'
	option apn 'custom.apn1'
	option area_type 'wan'

What are the owner/group/permissions on “files” and all its contents ?

This topic was automatically closed after 15 days. New replies are no longer allowed.