RUTX11 firmware update does not update (version stays them same, no errors)

I have a RUTX11 running 7.04.5, it is otherwise operating fine. I tried to update the firmware via server and by file to the latest 7.07.

Before the update, the GUI confirms the signature of the firmware, and I click PROCEED. The router appears to go through the process of updating the firmware, however, after the reboot, it is still at 7.04.5.

I have tried various combinations of this process with a mix of wired/wireless connection, 4g SIM card present/removed, performed factory reset. I have also tried to re-install 7.04.5 firmware, and also tried to upgrade to just 7.05.

In all of these cases, after reboot, the firmware is still at 7.04.5. No errors were evidenced in the log files, apart from the reboot.

Would someone be able to help me?

Did you try the recovery option via Bootloader already?
(See bottom of the page)

RUTX11 Device Recovery Options - Teltonika Networks Wiki


Could you please specify if you are trying to update your RUTX11 firmware version with keep settings or no?

Best Regards,

Yes, I have tried with and without the keep settings option. The strange thing is that even when I specified NOT to keep settings, it still rebooted with my old IP ranges, and not the factory defaults.

I haven’t tried the device recovery though, as mentioned above. I will try that today.

Thank you for confirming. Please keep me updated on whether the bootloader recovery option was helpful.

Best Regards,

I just tried the following:

  1. Perform factory reset by pushing reset for 12 seconds. Confirmed reset, because I am directed to the quick start and to set new admin password after first login. I then shutdown the router (no settings made)
  2. Reboot into recovery mode, and then uploaded 7.07.1 firmware image, and proceeded with update.

The router goes through the process again (I see the confirmation page indicating that the upgrade is proceeding, takes about 120sec, and it’s safe to close the window). The router reboots after this, but it is still at 7.04.5. Just in case this is a browser issue related to caching the page, I started a different browser that has not accessed this router before, and confirmed the firmware is really still at 7.04.5.

I’m really at a loss why the firmware cannot be updated even after a full factory reset, and in recovery mode.

The bootloader option initially did not work with the latest firmware. However, the other thing I tried was to upgrade to 7.05, that was a SUCCESS!

BUT, the next step I though was to update to 7.06, but that once again ended in failure. I tried to follow the same steps to update through the bootloader 2 times, but it failed. I then tried in the WebUI, and it still did not work.

So at the moment, I am now stuck at 7.05. At least it is a small step-up from 7.04.5.

I’ve continued to try to update the firmware in multiple ways, and experimenting with different settings (factory reset, boot loader/recover, webui, keep settings/don’t keep settings, different versions of firmware) and I’m not having any luck.

Worse yet, the router keeps indicating that it is updating the log database even after a factory reset. This doesn’t go away, and a process logread is very active, even after a factory reset.

I am thinking this unit may need to be RMA’d; I’ve tried contacting Teltonika on the Contact Us, but I’m not making any progress. Would someone here be able to help me?


Sorry for the late response. I sent you a form to fill out so I can connect with you privately and we can proceed. Please use ticket ID 5726.

Best Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.