RUTX11 Admin Access

Hi all,

I’m new to the world of Teltonika and have recently purchased a RUTX11 for use in my Motorhome. I have installed the unit added a SIM and it’s working fine. My issue and to my question is I can’t access the Admin section, I need this to setup GPS and login in to local Wi-Fi networks. I have tried the generic admin and admin01 to no avail. I have also tried the admin and the password on the sticker on the unit, nothing, I have also tried the used name / password for RMS (which I don’t need), any assistance will be greatly appreciated.


If the router wasn’t preconfigured in any way, the password on the device should be functional. Please double-check that you are entering it correctly and ensure that you are using the generated router password, not the Wi-Fi password.

If the issue persists, you can attempt to perform a factory reset on the device. This will erase all configurations on the device and should reset the password if it was previously set. Here is a quick guide on how to perform a factory reset for your device: Link to RUTX11 Device Recovery Options

Best regards,


Hi, thanks for taking the time to reply. I worked it out last night, I did a factory reset and it logged in straight away using the password on the label

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.