RUTX09 no more connected to RMS

Since a while, I’ve got a RUTX09 running like a charm and connected to RMS, but it’s been a few weeks now RUTX09 no more connected to RMS.
I’ve got no physical access to it, and I can’t connect directly to it. Somes SMS utilities still work (reboot, status, switch_sim, …).
There are many credit avaiblable on RMS, and periodic backups seems to still working.
Firmware version is RUTX_R_00.07.04.5
Metrics are no more transmitted.
Management services are ON.

SMS command “monitoring_status” report “monitoring - disable” but even if we send “rms_on” and “rms_connect” => no effect
command “RMS_status” => no answer

Any help would be really nice


You mentioned that the device was connected to RMS before. Did you change anything within device configurations? Maybe you updated the firmware or use a different SIM card?

I assume the monitoring is enabled in RMS itself? Management → Devices → Your device → Device → Manage Services:

You could please try removing the device from RMS and adding it again?

Kind Regards,

Hi AndzejJ,
Thanks for your answer.
The only change was upgrading to the latest firmware, no SIM card modification.
RMS is enabled.
I’ve removed the device and add it again, then try SMS commands:
without expected results… :frowning:

SMS command: Monitoring_status still indicate “Monitoring - disabled”

Theses SMS commands seems to only obtain answer on one of the two SIM cards, but it was OK on the both before firmware upgrade.

reboot has no more effect

Any other idea ?


What firmware firmware version you had before the update? Did you update with ‘keep settings’ enabled?

Do you have access to the device? Would it be possible for you to try the following:
Navigate to Services → NTP → General and sync time.
Navigate to Network → Interfaces → edit mob1s1a1 interface → Advanced settings and try lowering MTU manually? Values to try are 1460, 1360, 1260.

If this does not help, could you please check the ‘connection state’ in Services → Cloud Solutions → RMS? What does it say?

Kind Regards,

many thanks for your answer.
Can’t remember exactly which firmware version it was before, but I maycheck it in an old backup if you tell where to find it.
I’ve got no access to it, so I couldn’t verify what you said.
Only SMS commands to interact with it. :frowning_face:

but SMS command “monitoring_status” says “monitoring disabled” even after “rms_on” and “rms_connect” commands.
Is there anyother command that I may send to unlock the situation ?
I’ve try SMS command “reboot”, it has restarted, but without any better effect after.



With SMS, I am afraid there’s not much that can be done here. You could try lowering MTU or restarting RMS with UCI, but for RMS this would be similar to using rms_on and rms_connect:

admin01 uci set rms_mqtt.rms_connect_mqtt.enable=0
# and
admin01 uci set rms_mqtt.rms_connect_mqtt.enable=1
# you can try lowering MTU with SMS as well (mob1s1a1 assuming SIM slot 1 is used):
admin01 uci set network.mob1s1a1.mtu=1360

Perhaps there was some configuration changes on the device that caused it to disconnect from RMS? Or maybe you updated the firmware?

Kind Regards,

A possible reason to lose RMS is that quite many stupid mobile operators decide to randomly assign a private IP as DNS to the 4G subscriber.
They have plenty of public IPs or they could use other ranges of private IPs, but they know better don’t they ? :slight_smile:
So if they assign as the default DNS (as it it the case here in France with some specific Orange SIMs), and if you use 192.168.10.X on the LAN interface, you are not going to receive DNS replies anytime soon.
So the RUT won’t be able to connect to


Thanks for your information. I’m going there tomorow morning, I’ll try to find out what’s going on, but I’ll have less than a quarter to resolve…

This topic was automatically closed after 15 days. New replies are no longer allowed.