RUTX08 firmware RUTX_R_00.07.06.6 wan static ip address bug

Since ive upgrade to the latest firmware RUTX_R_00.07.06.6 i cannot change my WAN ip static ip address. When i click on “Save & apply” nothing is happening. Tried 3 different browser (Edge - Chrome - Firefox) in incognito mode and they all do the same thing

Ive tried reseting the router to factory default, ive tried another RUTX08 router and all of them do the same thing. if i downgrade to version RUTX_R_00.07.06.5 it’s working fine

Can you fix that please. I think you should be more carefull when you release new firmware as ive seen a lot of bugs with different new firmware by time to time using different router from you guys

Thanks !


I apologize for any inconvenience this issue may have caused. Rest assured, our development team is fully aware of the situation and is actively working to implement a solution. We are currently in the process of resolving the issue, and you can expect it to be addressed in the upcoming firmware updates. Thank you for your patience and understanding.

Best Regards,

Ok thanks for the news

Is this fix in new firmware R_00.07.06.8 ??

This topic was automatically closed after 15 days. New replies are no longer allowed.


Yes, with the RUTX_R_00.07.06.8 firmware version, you can now change WAN to static as before.

Best Regards,

Ok thanks !

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.