RUTX Modem Firmware update process

Hello. Looks RUTX series has some issues with modem upgrade via GUI.
After upgrading to 7.4.5 (RUTXR1) I tried to update modem firmware from GUI, and it does nothing in the end. Just shows banner “Modem update is in progress… Do not power off the device.” for a very long time. Nothing interesting was shown in logread output.
Correction: Web update works, but sometimes it just fails.

After that I run from ssh: dfota -u
This command actually connects to modem’s vendor server, download and install correct firmware.
Surprise for me was multi step upgrade, from
EG06ELAR04A04M4G > EG06ELAR04A07M4G > EG06ELAR04A08M4G > EG06ELAR04A20M4G

So, is such path mandatory, or I may somehow skip to latest version? And how to find, what is latest version?

P.S. every time duering “dfota -u” execution, i had following error:
[get_tap_info:135] error: Failed to load ‘device_management’ package

Is it modem’s vendor issue or Teltonika’s ?

1 Like


Thank you for your question.

There is another way to update your modem firmware using modem_updater package.

Before attempting the update, you need to connect your router to a different WAN source, either wired or wireless. Below are the instructions:

Please access your device via SSH and execute the following commands:

  • opkg update
  • opkg install modem_updater
  • opkg install sshfs
  • modem_updater -g

The last command will list available firmware versions. Next modify the following command:

  • modem_updater -i <ID> -v <VERSION>
    • <ID> : should be 3-1, however, in case of an error you should be shown a correct ID.
    • <VERSION> : enter the latest firmware version from the list of the previously executed command, it should be EG06ELAR04A20M4G.

The firmware update may take a few minutes, once it’s done you can check your modem firmware version either via the WebUI or via this CLI command : modem_updater -g

Let me know if you have any other issues updating your modem firmware.

Best regards,


thanks for your answer, but I’ve problems to connect via ssh or CLI. Is there a hidden admin user? My admin and password don’t work. See screenshots:

Bildschirmfoto 2023-08-13 um 08.08.19


And the second screenshot

for web login : admin
for ssh/telnet/sftp login is: root
password is the same as for web login.

Thank you but I’ve only the teltonika to access the internet. I’m on the road with my camper and the most places have hotspots which doesn’t work anyway.

May be there comes an update as file sometimes which can be installed as usual.


This topic was automatically closed after 15 days. New replies are no longer allowed.