RUT956 SMS Error

RUT956 login: root

BusyBox v1.34.1 (2023-05-17 08:00:50 UTC) built-in shell (ash)

| _ \ _ | | / _ / |
| |
) | | | | | | | _ \
| _ <| |
| | |
| || |) |
| _\

Teltonika RUT9M series 2023

root@RUT956:~# gsmctl -S -s “004560190000 HEllO”
[gsmctl_send_sms:20] error: ERROR: Failed to parse response

i’ll tryed webui sms sender, http post/get, and let the system response to a ingoing command.
auto answer.

and none of them is working.

it can recive but no matte what i try it wont send any SMS

i’ll read some of the other topics and tryed to tjeck for latest update and still no help.


Could you try sending an SMS using the ubus command? What is the output of the command?:

  • ubus call gsm.modem0 send_sms ‘{“number”:“+37001010101”,“text”:“ubustest”}’

Also, can you run the following commands and share the output?:

  • gsmctl -A ‘at+csca?’
  • gsmctl -A ‘at+qcfg=“servicedomain”’
  • gsmctl -A ‘at+qcfg=“nwscanmode”’

Kind Regards,

root@RUT956:~# ubus call gsm.modem0 send_sms ‘{“number”:“+4560190000”,“text”:“ubustest”}’
Command failed: Request timed out

root@RUT956:~# gsmctl -A ‘at+csca?’
+CSCA: “+4528187000”,145
root@RUT956:~# gsmctl -A ‘at+qcfg=“servicedomain”’
root@RUT956:~# gsmctl -A ‘at+qcfg=“nwscanmode”’


Whats it the connection state in Status → Network → Mobile?

For the testing purposes, can you change the Network type in Network → Mobile → General to 2G or/and 3G only and then try sending an SMS.

Kind Regards,

2G+3G seems to work.


Could you set the device back to auto or 4G, then execute the following command:

  • ubus call gsm.modem0 exec ‘{“command”:“AT+QNVFW="/nv/item_files/modem/mmode/sms_domain_pref",00”}’

After that, reboot your device and try sending SMS message again.

Kind Regards,

root@RUT956:~# ubus call gsm.modem0 exec ‘{“command”:“AT+QNVFW=”/nv/item_files/modem/mmode/sms_domain_pref",00"}’
Failed to parse message data

I still cant sent with other then 2G Or 3G


Apologies for the delayed response.

It seems that I missed the formating of the command a bit. Sorry about that. Here’s a fixed one:

ubus call gsm.modem0 exec '{"command":"AT+QNVFW=\"/nv/item_files/modem/mmode/sms_domain_pref\",00"}'

Let me know how it goes.

Kind Regards,

1 Like

root@RUT956:~# ubus call gsm.modem0 exec ‘{“command”:“AT+QNVFW="/nv/item_files/modem/mmode/sms_domain_pref",00”}’
“request”: “AT+QNVFW="/nv/item_files/modem/mmode/sms_domain_pref",00\r”,
“response”: “\r\nERROR\r\n”


Could you please tell me the modem used in your device? You can find it in Status → System.

Kind Regards,

SLM750-VE (fw: SLM750-V_4.57.20_EQ101)


Apologies. I assumed that the device you have is with a Quectel modem.

Can you try the following command?

ubus call gsm.modem0 exec '{"command":"AT+CGSMS=1"}'

Kind Regards,

I set it back to Auto
Send the comand (Responce ‘OK’)
Rebooted and tryed to send a SMS
But not Nothing

Then I set it back to 4G
Send the comand (Responce ‘OK’)
Rebooted and tryed to send a SMS
But not Nothing

So it still doesn’t seem to work.

i was getting lgsm error 4 on rut240 quectel. after updating to 7.04.5, i sent a couple of smses then it stopped working. found this topic, switch to 2G+3G, worked, switched back to 3G+4G, stopped working again. ran the above command and that fixed it.

do not work for me.

yeah, it’s started failing for me, again


Please, try setting VOLTE in Network → Mobile manually to ON or OFF, depending on what your provider allows.

It is possible that the APN you are using does not allow for SMS messages over LTE. Could you please check your APN for your operator to see if it allows SMS messages over LTE? If possible, try a different APN. APN can be set in Network → Interfaces → mob1s1a1 .

Could you try putting the SIM card into your phone and checking if it sends an SMS message? What APN is used when the SIM card is inserted into your phone?

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.