RUT956 ServerMQTT doesnt work

hi i have a mosbus TCP client that is conected with a modbus slave.
I already set my rut956 has a MQTT broker:
MQTT broker enable,port 1883, enable remote access. The router ip is, the slave ip is

Then i create a Data to Server
server address, port 1883, keepalive 60, topic Voltage client ID 1.

And the last part was create data configuration type modbus, data filtering ip address, server ip, segment count 1

With all that configured i cant read the data from the server


The configuration within the provided looks correct.
However, a few suggestion would be:

  • Check the Anonymous access option in the Miscellaneous settings of the MQTT Broker service. This option is disabled by default in firmware versions 07.05 and higher. If you want to use anonymous access, you need to enable it manually.
  • Send me a screenshot of the Modbus Client configuration. This will help me to see if there are any errors or misconfigurations in your settings.
    If that does not help, could you also attach a screenshot of the Modbus Client configuration?
  • Consider changing the IP address for MQTT broker to in the Data to Server service. This is the loopback address on our devices, which means it will always point to the local MQTT Broker. This way, you don’t have to worry about changing the IP address if the router’s IP address changes. This is optional and it won’t affect the functionality of the service.

Let me know how it goes!

Best regards,


When pressing the TEST button in Modbus Client configuration is the data returned successfully?

Additionally, I’d suggest leaving the MQTT Client ID field empty, as then it will use a random string, which will hopefully avoid any conflicts. If two or more MQTT clients have the same ID, they will not be able to transmit the data properly.

Best regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.