RUT955 Sending swedish characters not received correctly

Sending sms with gsmctl -S -s command.
When text sent contains any swedish characters åäöÅÄÖ or two consecutive spaces some receivers (calling it X here) does not understand this and the entire message is unreadable.

Works when sending from/to:

  • RUT955/RUT955
  • RUT955/Mobile phone
  • Mobile phone/X

Not working when sending from/to:

  • RUT955/X

We do not have any specifications on X (emergency central handling incoming alarms). We suspect it only supports PDU format.

Any ideas on what could be the issue?
Does gsmctl use PDU or Text mode? Can this be modified?


I tried sending these characters using ‘gsmctl -S -s’ command and was able to receive them successfully. Thus, make sure you are running the latest firmware version.

The gsmctl command cannot send SMS in PDU mode because gsmd converts it to PDU when sending. If you want to explicitly send SMS in PDU mode, you can use AT commands. For example, by using microcom or putty (modem control information here). You can also find an example of an AT command on the old forum here.

Kind Regards,

We are using the latest firmware and like we stated it works to most devices.

We noticed one thing.
When sending from mobile phone it is sent with data coding - SMS Default Alphabet.
When sending from RUT955 data coding is - Unicode.

This is most likely the reason why it works from mobile phone and not from RUT955.

Can you confirm you are using Unicode? Is there anyway to change this to SMS Default Alphabet?


Apologies for a late reply.

In this case, I suggest sending SMS in PDU mode as mentioned before. In your case, you can check what modem is used in your device in Status → System and search online for official AT commands documentation for that specific modem. You will find information about AT commands to send SMS messages and options used within those commands.

Kind Regards,

Thanks for the response but you did not answer my question regarding Unicode


By default, it uses GSM. However, when the message contains characters that cannot be expressed in GSM, it switches to Unicode/UCS2 encoding. If the SMS includes at least one of these special characters, the entire text is encoded using UCS2, resulting in a maximum message length of 70 characters for a single message, as opposed to the standard 160 characters allowed when using GSM encoding.

When sending with AT commands, you can check if PDU or text is used via:


To check encoding:


Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.