RUT955 - Modbus TCP over Serial Gateway does not listen on port

Greetings,

I am working with a RUT955:

Firmware version: RUT9_R_00.07.06.3
Firmware build date: 2024-01-12 18:01:34
Internal modem firmware version: SLM750_4.0.6_EQ101
Kernel version: 5.4.259

and want to use the “Modbus TCP over Serial Gateway” functionality.

I also followed the description you can find here.

No matter what I do, the TCP port, on which the gateway should be listening, is closed.
(I also confirmed it with an nmap scan.)

What I tried so far (in combination and different order):
~ reboot after configuration
~ checking the event log
~ use of an unprivileged TCP port (10001)
~ confirmed a working TCP port listening state with the “Modbus TCP Server” service.
~ checking the firewall rules
~ and various parameter combination for the gateway.

Can some body please confirm this problem or help me with my configuration.

Thx in advance …

PS.: i wanted to upload my troubleshooting file but got following message
“Sorry, new users can not upload attachments.” …

1 Like

Can you reproduce the same errors as I’m getting in this post TRB245 modbusgwd crashing ?

@duzk, sorry I can’t find any similar entries in the event logs of the WebGUI and the syslog file via CLI (and logread) is empty …
how did you acquire the syslog entries in your post?

This is the logs from the CLI tool logread
I turned the logread -f and then turned on the modbus tcp to serial server and watched the output.

hmmm, I did the same, but nothing showed up …

I tried it again with “logread -f” on the CLI, but nothing showed up. This is very strange!

Hello @nuxvomica,

While I am not fully aware of the settings you have, could you please first try to disable Modbus server on RUT955 and put 0.0.0.0/0 into IP filter on the Modbus TCP over Serial configuration page (if you are trying to access via WAN, make sure you select WAN interface).

If this does not help, please share your current configurations here. Also, please provide more details on what exactly are you trying to do.

Kind Regards,

Hi @AndzejJ ,

I have uploaded the troubleshoot file from the RUT955 I was using.
In the mean time I tried it with two RUT955 with the same firmware version, and they have the same problem.

Yes, I did disable the Modbus Server and used 0.0.0.0/0 as an IP filter.
I am also only using the LAN interface. (But you will see this in the troubleshoot file.)

“Also, please provide more details on what exactly are you trying to do.”:
I want to read Information of a Modbus RTU slave via the Modbus gateway on the RUT955 using a Modbus TCP client on a PC.

Exactly depicted in the description you can find here .

Like described in my very first post, the port the gateway should listen to is closed, so I can’t use the Modbus gateway feature.

Thx in advance.

troubleshoot-Teltonika-RUT955.com-2024-01-30.tar.gz (97.9 KB)

Hi @AndzejJ,

can you please let the topic open until there is a solution to this problem.

Thx in advance!

This topic was automatically closed after 15 days. New replies are no longer allowed.

Hello @nuxvomica,

Apologies for the delayed response.

It seems that something is causing the service to segfault.

Although the settings themselves are fine, could you please try changing serial settings such as parity / flowcontrol / duplex?

Also, would it be possible for you to downgrade one of the devices to v7.06 to see if the issue persits? If feasible, it would be great if you downgrade the device without settings.

Let me know how it goes.

Kind Regards,

Hello @AndzejJ,

I tried three different firmware version on the following device:

Product code: RUT955003XXX
Bootloader version: 4.2.0
Serial number: 6001154679
Hardware revision: 2727
Batch number: 0136

During the tests I changed the serial settings and other parameters.
Always loaded the firmware “without settings” and also used the default settings for a subtest.

During the tests I connected via CLI and run “logread -f” but there are no syslog entries, what so ever.
This also should be fixed.

Following the result:

**PASSED**
Firmware file: [RUT9_R_00.07.06_WEBUI.bin](https://firmware.teltonika-networks.com/7.6.3/RUT9/RUT9_R_00.07.06.3_WEBUI.bin)
Firmware version: RUT9_R_00.07.06
Kernel version: 5.4.259
**PASSED**
Firmware file: [RUT9_R_00.07.06.1_WEBUI.bin](https://firmware.teltonika-networks.com/7.6.1/RUT9/RUT9_R_00.07.06.1_WEBUI.bin)
Firmware version: RUT9_R_00.07.06.1
Kernel version: 5.4.259
**FAILED**
Firmware file: [RUT9_R_00.07.06.3_WEBUI.bin](https://firmware.teltonika-networks.com/7.6/RUT9/RUT9_R_00.07.06_WEBUI.bin)
Firmware version: RUT9_R_00.07.06.3
Kernel version: 5.4.259

There is nothing written in the change log for the RUT9_R_00.07.06.3 version, except changes in the " Global RUTOS":

**R_00.07.06.3**

    Improvements
        Services
            Added multiple hosts support for GPS HTTPS, NMEA and AVL services
            Increased DLMS Client connection timeout for TCP sockets

    Fix
        Services
            Fixed DLMS Client memory leak with profile generic COSEM class
            Fixed function 5 not working with high register numbers in MQTT Modbus Gateway service
        WebUI
            Fixed Events Log sorting and search features
        System
            Patched CVE-2024-0193 vulnerability
            Patched CVE-2023-51779 vulnerability
            Updated OpenSSH to 9.6p1 version, fixed CVE-2023-51385 and CVE-2023-51384
            Fixed profile migrations, added error handling when trying to change profile while it is still applying

Looks there is a problem with the new firmware version and pleas fix the syslog problem.
I will also attach the troubleshooting files from the three tests.

Thanks in advance

troubleshoot-RUT9_R_00.07.06-2024-02-08.tar.gz (108.9 KB)
troubleshoot-RUT9_R_00.07.06.1-2024-02-08.tar.gz (109.6 KB)
troubleshoot-RUT9_R_00.07.06.3-2024-02-08.tar.gz (114.8 KB)

Hello @nuxvomica,

Thank you for providing the files. They are greatly appreciated.

Upon reviewing the troubleshoot files, it appears that there are indeed some issues. I will forward this information to our RnD department for further investigation. In the meantime, I recommend sticking with version 7.06.1.

I will keep you updated as soon as I have more information.

Kind Regards,

This topic was automatically closed after 12 days. New replies are no longer allowed.