RUT955 LAN-port not recognized by pc

I am having issues with connecting to my RUT955 via LAN. The router is successfully connected to the internet with a sim and has the latest firmware installed. It also detects the LAN-cable and responds with the blinking and then permanently put on LED underneath the LAN-port and the messages “Port link state of port LAN1 changed to UP”, “Port speed for port LAN1 changed to 100 baseT” in the troubleshoot file.
But my issue is that when plugging the LAN cable into my Windows 11 computer, no connection is recognized.

I already tested it with multiple cables and computers and resetting the router. The computer settings should also be correct, as I frequently use the computers for setting up RUT955’s via LAN.

Hello Ivo,

I am sorry to hear about your issue connecting via LAN.
I am happy to help assist troubleshooting your issue.
If I could have your assistance collecting/confirming some additional information about your issue:

  1. You mentioned your Win 11 computer was unable to recognize the connection. Can you do the following steps and provide screenshots.
    1. Press & hold the reset pinhole on the RUT955 for 15-20seconds. It should finish resetting in ~5mins. This is so we can troubleshoot from a clean start once more, and it should set the LAN IP back to 192.168.1.1/24.
    2. Once the RUT955 has been reset & is back online please connect a ethernet cable between LAN port 1 (Left most port) & to your Win 11 Computer.
      Disconnect any additional cables & remove any SIM cards for now.
    3. On your Win 11 Computer confirm from the Control Panel that your Ethernet interface connected to the router shows a connection & is setup to automatically receive a IP address.

If you have Wifi or other interfaces available on the device please right click on them in the Control Panel & ‘Disable’ them for now.Take a screenshot of this

  1. On your Win 11 Computer, hit Winkey + R → This should open a search bar. Type in ‘cmd’ & hit Enter.
    Or simply type in the Windows search bar ‘cmd’ and hit Enter.

  2. In the cmd window that should have opened, type in the following: ipconfig /all

  3. Look for the following in the result: Ethernet adapter Ethernet.
    Take a screenshot of this.
    Confirm if you see an IP in the range of 192.168.1.100-254.
    You should also see under the same adapter the Default Gateway & DHCP Server listed as ‘192.168.1.1’.

  4. If you DO see an IP assigned to this interface, run this command: ping 192.168.1.1
    Take a screenshot of the result.

  5. If you do NOT see a reply from the ‘ping’ command please run this command: route print
    Take a screenshot of the result

  6. If you were not able to get a reply on the ‘ping’ command, please repeat the sub-steps 2-8 after moving the cable to LAN 2 on the router. And repeat again for LAN 3 on the router.

  7. For the additional computers you have tried, what OS were they running? Windows 10/11, Linux or MacOS?

  8. You also mention setting up multiple RUT955s. Has this problem only occurred in this one device?

  9. Did you download the troubleshooting file via the public IP of the SIM, RMS or Wifi?

  10. Have you had similar problems connecting to the WebGUI via Wifi?

After you have provided your answers & screenshots of initial troubleshooting steps with me I can assist further.

Thank you for your reply, i followed the steps and gained the following information:

ipconfig /all:

ping

route print

the same output was produced on different Lan ports of the RUT955.

Reagarding your questions:
10. All of the computers are running Windows 11
11. Yes, I never had this issue before
12. I downloaded it via WiFi
13. No, everything works fine via wifi

Thank you for your help!

Hello Ivo,

Thank you for your responses.

I can see that the RUT955 does not seem to be communicating via DHCP at least so far.

If the LAN port LED light is blinking green when you plug your cable in we can try statically giving your Win 11 PC a 192.168.1.2 255.255.255.0 ip and see if you can ping the 192.168.1.1

Also can you confirm after you reset the device, if you connected via Wifi were you able to go through the Setup Wizard again?

If you could provide screenshots after following these steps:

  1. On your Win 11 Computer please open your Control Panel → Network and Internet → Network Connections.

  2. Make sure all other interfaces are disabled, besides your ethernet connecting to the RUT955, by right clicking on them and selecting ‘Disable’.

  3. Right click on your Ethernet interface that is connected to the RUT955, select Properties. Click on ‘Internet Protocol Version 4 (TCP/IPv4)’ → Properties.

  4. Select ‘Use the following IP address’.

For IP address: 192.168.1.2
For Subnet mask: 255.255.255.0
Default gateway: 192.168.1.1

  1. Please take a screenshot of the config here.
    Select ‘OK’

  2. Select ‘Close’ on the ‘Ethernet Properties’ window for changes to take effect.

  3. Hit Winkey + R → This should open a search bar. Type in ‘cmd’ & hit Enter.
    Or simply type in the Windows search bar ‘cmd’ and hit Enter

  4. See if you can ping 192.168.1.1
    Screenshot your results.

If you do not get any ping returns repeat the same steps as before, but this time give yourself a 192.168.1.10 IP.

I want to try this 1st in case there is something wrong with DHCP between the RUT device & your Win 11 device.

The next thing we can try is downgrading the Firmware. BUT I would only try this after 1st attempting the 1st method I provided.

This method may still not work if there is physical problem with the LAN ports.

Before that can you confirm what Firmware Version you are currently at?

If you are not on RUT9_R_00.07.06.11 I would recommend upgrading to this newest via Wifi or with your SIM card, before we try downgrading.


CAUTION: This method uses our emergency bootloader to downgrade the Firmware. If power is lost to the devices or the connection is lost between the Win PC & the RUT955 it could brick the device.

BEFORE starting please confirm you have a stable power source to both your RUT955 & Windows PC.

This will take up to 10-20 minutes to finish, please make sure your Windows PC does not go into sleep mode.

Follow the instructions listed here on our Wiki (link below).

When downloading the firmware for your RUT955, do NOT go lower than a Single version available.

For example Current Version: RUT9_R_00.07.06.11

I would not go lower than RUT9_R_00.07.06.10

And you will want to access the Firmware upgrade URL 192.168.1.1/index.html

NOT the /uboot.html

https://wiki.teltonika-networks.com/view/Bootloader_menu

After a successful Firmware downgrade I would repeat our previous troubleshooting steps to check for connectivity.

I can provide further assistance afterwards.

This topic was automatically closed after 15 days. New replies are no longer allowed.