RUT955 default route to LAN not working

Hi,
I have RUT955 which is ONLY connected through LAN (as part of electricity measuring solution).
Device has a fixed IP-address.

Using the GUI, I did not find a way to add DNS-service settings, so I used SSH CLI to add servers into the /etc/config/network -file

–clip starts–
config interface ‘lan’
option proto ‘static’
option netmask ‘255.255.255.0’
option ipaddr ‘192.168.100.7’
option gateway ‘192.168.100.1’
option area_type ‘lan’
option device ‘br-lan’
option dns ‘193.229.0.40 193.229.0.42 8.8.8.8’
option igmp_snooping ‘0’
option delegate ‘0’
option force_link ‘1’

config device ‘br_lan’
option name ‘br-lan’
option type ‘bridge’
list ports ‘eth0.1’
option stp ‘0’

config route ‘1’
option table ‘254’
option netmask ‘0.0.0.0’
option gateway ‘192.168.100.1’
option target ‘0.0.0.0’
option interface ‘lan’

config route ‘4’
option table ‘254’
option netmask ‘255.255.255.255’
option gateway ‘192.168.100.1’
option target ‘8.8.8.8’
option interface ‘lan’
–clip ends–

What is odd, that even when default route is defined to be this br-lan,
it is not working.
Only way to for example get DNS requests working to google, is to add a static route to 8.8.8.8,
which points to this interface.

Question? how to make the default routing work without need to add a static route to each destination address?

Here is ip route -info:
–clip starts–
root@Teltonika-RUT955:~# ip route
default via 192.168.100.1 dev br-lan proto static
8.8.8.8 via 192.168.100.1 dev br-lan proto static
192.168.100.0/24 dev br-lan proto kernel scope link src 192.168.100.7
–clip ends–

Device info:
Device: RUT955
Kernel: 5.4.259
Firmware: RUT9_R_00.07.06.17
Build: a4aefd8a170
Build date: 2025-01-06 07:09:12

Hello,

Complementary DNS servers can be added through the WebUI in Network → DNS. There is no need to add them via SSH, and for reference, DNS server settings are actually located in the /etc/config/dhcp.

Could you clarify what you are trying to achieve? From your description, it seems like you want your RUT955 to use 192.168.100.1 as the default gateway. Assuming your RUT955 is connected to the 192.168.100.0/24 network, you can specify the default gateway in Network → WAN under the wan interface settings:

If that is not the case, could you provide a simple network topology of your setup?

Best regards,

Ok,

So instead of using one of the LAN-ports to connect to the device, I should connect the WAN-port.
Now that makes sense. I see that on WAN-port config side, there are options for DNS-servers and such.

Internet ↔ Router ↔ RUT955 (iOT-measurements)

The measured device is also connected to the Router.
And all the management of the RUT955 is done from the Router-side connected PCs.

So I turned off the firewall on the RUT955 WAN-port, to allow all input/output/forward traffic.

I’ll give this a try.

The change is done, but it did not help with the DNS issue:

All the other interfaces are disabled. Only WAN is enabled.

Routing table is very clear:
–clip starts–
root@Teltonika-RUT955:~# ip route
default via 192.168.100.1 dev eth1 proto static
192.168.100.0/24 dev eth1 proto kernel scope link src 192.168.100.7
–clip ends–

Trying to make DNS request fails:
–clip starts–
root@Teltonika-RUT955:~# ip route
default via 192.168.100.1 dev eth1 proto static
192.168.100.0/24 dev eth1 proto kernel scope link src 192.168.100.7
root@Teltonika-RUT955:~#
root@Teltonika-RUT955:~# nslookup www.google.com
;; connection timed out; no servers could be reached

root@Teltonika-RUT955:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network unreachable
root@Teltonika-RUT955:~#
root@Teltonika-RUT955:~# traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 46 byte packets
1traceroute: sendto: Network unreachable
–clip ends–

The /etc/config/dhcp is following:
–clip starts–
config dnsmasq
option domainneeded ‘1’
option boguspriv ‘1’
option filterwin2k ‘0’
option localise_queries ‘1’
option rebind_protection ‘1’
option rebind_localhost ‘1’
option local ‘/lan/’
option domain ‘lan’
option expandhosts ‘1’
option nonegcache ‘0’
option authoritative ‘1’
option readethers ‘1’
option leasefile ‘/tmp/dhcp.leases’
option dhcpscript ‘/usr/sbin/dhcpinfo.sh’
option resolvfile ‘/tmp/resolv.conf.d/resolv.conf.auto’

config dhcp ‘wan’
option interface ‘wan’
option ignore ‘1’
–clip ends–

and finally the /etc/config/network -file looks like this:
–clip starts–
root@Teltonika-RUT955:/etc/config# cat network

config globals ‘globals’
option ula_prefix ‘fd2b:5b70:9d07::/48’

config interface ‘loopback’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’
option area_type ‘lan’
option device ‘lo’

config interface ‘lan’
option area_type ‘lan’
option device ‘br-lan’
option igmp_snooping ‘0’
option disabled ‘1’
option force_link ‘0’
option proto ‘none’

config interface ‘wan’
option area_type ‘wan’
option device ‘eth1’
option netmask ‘255.255.255.0’
option force_link ‘0’
option broadcast ‘192.168.100.255’
list dns ‘193.229.0.40’
list dns ‘193.229.0.42’
list dns ‘8.8.8.8’
option peerdns ‘0’
option proto ‘static’
option gateway ‘192.168.100.1’
option delegate ‘0’
option ipaddr ‘192.168.100.7’

config interface ‘wwan’
option proto ‘dhcp’
option disabled ‘1’
option metric ‘20’
option area_type ‘wan’
option device ‘wlan0’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option ports ‘0t 2 3 4’
option vid ‘1’
option vlan ‘1’

config interface ‘mob1s1a1’
option metric ‘10’
option mtu ‘1500’
option volte ‘0’
option proto ‘wwan’
option sim ‘1’
option pdp ‘1’
option modem ‘1-1.4’
option method ‘nat’
option area_type ‘wan’
option pdptype ‘ip’
option auto_apn ‘1’
option force_apn ‘-1’
option disabled ‘1’

config interface ‘mob1s2a1’
option proto ‘wwan’
option sim ‘2’
option pdp ‘1’
option auth ‘none’
option modem ‘1-1.4’
option method ‘nat’
option area_type ‘wan’
option pdptype ‘ip’
option auto_apn ‘1’
option force_apn ‘-1’
option disabled ‘1’
option delegate ‘1’
option metric ‘11’
option force_link ‘0’

config device ‘br_lan’
option name ‘br-lan’
option type ‘bridge’
list ports ‘eth0.1’
option stp ‘0’

config rule ‘5’
–clip ends–

But, once I add a STATIC route pointing to WAN, then routing seems to start working!??!
Why is this?

And from CLI doing ping, nslookup and ip-route
–clip starts–
root@Teltonika-RUT955:/etc# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=59 time=1.321 ms
64 bytes from 8.8.8.8: seq=1 ttl=59 time=1.158 ms
^C
— 8.8.8.8 ping statistics —
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 1.158/1.239/1.321 ms
root@Teltonika-RUT955:/etc#
root@Teltonika-RUT955:/etc#
root@Teltonika-RUT955:/etc#
root@Teltonika-RUT955:/etc# ip route
default via 192.168.100.1 dev eth1 proto static
8.8.8.8 via 192.168.100.1 dev eth1 proto static metric 1 mtu 1500
18.196.62.30 via 192.168.100.1 dev eth1 proto static metric 1 mtu 1500
192.168.100.0/24 dev eth1 proto kernel scope link src 192.168.100.7
root@Teltonika-RUT955:/etc# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=59 time=1.254 ms
64 bytes from 8.8.8.8: seq=1 ttl=59 time=1.178 ms
^C
— 8.8.8.8 ping statistics —
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 1.178/1.216/1.254 ms
root@Teltonika-RUT955:/etc# nslookup www.google.com
Server: 127.0.0.1
Address: 127.0.0.1#53

Name: www.google.com
Address 1: 216.58.210.164
Address 2: 2a00:1450:4026:802::2004
–clip ends–

YES!!!

Looking through all the options: In the Network → Failover
There is an interface called ‘-’ (just a single dash!), which was enabled.
When disabled, then the routing started working!

Looking at that interface config, is it like this:

Thank you for the update! It’s great to hear that you managed to solve the issue.

For future reference, it’s usually worth performing a factory reset before making any configurations, as the necessary static routes should be present by default when the correct gateway is specified in Network → WAN. Additionally, please ensure that the LAN IP subnet (Network → LAN) does not overlap with the WAN interface subnet to avoid conflicts.

Kind regards,

It it really the multiwan interface called: wwan0

Checking on the /etc/config/mwan3
we have it here:
–clip starts–

config interface ‘wwan0’
option family ‘ipv4’
option enabled ‘0’
option interval ‘99’

config member ‘wwan0_member_mwan’
option interface ‘wwan0’
option metric ‘3’

config condition
option interface ‘wwan0’
option track_method ‘ping’
option reliability ‘1’
option count ‘1’
option timeout ‘3’
option down ‘3’
option up ‘3’
list track_ip ‘8.8.4.4’

–clip ends–

the mwan3 -file was missing this section for that interface:

config member ‘default_wwan0_member_balance’

Which I added like this:
–clip start–

config member ‘default_wwan0_member_balance’
option ifname ‘wwan0’
option weight ‘2’
–clip ends–

But the Interface name still shows up as ‘-’ in the failover section.

Well, the device works as expected. So I will not care about that ‘-’ failover interface.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.