RUT955 connected to 4g LTE but no internet connection

Hello Team,
I have a RUT955 running on Firwware v.RUT9_R_00.07.04.5 (the latest) that despite shows 4G LTE "connected"on the “Status” menu , is not able to be connected to internet. I would like to point out the router worked perfectly for weeks with the same configuration (nothing was changed ! ) , even if it was running on a lower version of firmware , then suddenly started to have this issue. The problem is not the Firmware since the same behavior was present with
The problem is not due to the roaming since I started to have this connectivity issue also in the places where I use to be connected without any problem.

What I did to try to fix tis connectivity issue :
1# firmware upgrade ( see above ) did not solve it
2# check again the settings (attached) , i.e. APN (,WAN set to mobile ,auto APN off/on (now is off ,set to manual ) ,NAT enable ,tried to disable VoLTE in Network → Mobile → General;
Try to Lock service mode to LTE-only;• Try selecting a different band (e.g. B3) by navigating to Network → Mobile → General settings, selecting LTE-only mode, and only selecting B3, Tried the settings below (from other topics)

used everywhere as the APN
Tried to lock bands > B1, B3, B7, B40
Tried auto select ( it was working before ! )

Tried also NOT in roaming in the city where normally it was working , same issue.

I have the troubleshooting log but it seems I do not have the right to upload it.

Many thanks in advance for any input you could provide.



Just to clarify, your actual operator is EE, correct? This APN is only intended to be used on their network (even when roaming).
However, since Data connection state is Connected, I doubt the issue is with the actual mobile connection. Here are a few suggestions:

  • Navigate to Network → Interfaces → General, edit the mob1s1a1 (SIM1) or mob1s2a1 (SIM2) interface, and under the Advanced Settings tab set the Override MTU option to 1350;

  • While editing the same interface, under the Advanced settings specify the DNS servers manually as and

  • I’d also suggest removing the manual band locks, and other settings changed during the troubleshooting, just to avoid any other issues.

Best regards,

Hi thanks mate for your prompt replay.
The operator is FASTWEB ( Italy that uses the TIM Network ) in fact the APN is NOT EE ( i may have pasted an example from other posts I am sorry for that).

I will check your suggestions and revert back to you.

Have a nice day ahead , best regards :


Sure, let me know how it goes!

Best regards,

Hi Daumantas , during the weekend I did several tests and changed the parameters you suggested.
You will find all the details /configuration snapshots / logs here :

[redacted by moderators]

Unfortunately the interface is still showing “4G connected” but no internet on my laptop / cell phone.

In a nutshell what I did :
1# double check the APN , it was correct and working before with ( i was NOT in ROAMING status ) , tried in Italy / Milan where I live.
2# tried different MTU as you suggested , i.e. 1350 , 1260 ,1460
3# added DNS and tried also FASTWEB suggested DNS , no internet at all
4# removed any band lock and any former settings
5# remove any FIREWALL settings ( see attchments / logs )

Any ideas ? it may be a SIM issue ? Do we have any CLI commands to test the SIM hardware ?
The only thing I have to do now is to test the FASTWEB SIM in another cell phone OR to reset the router to factory default.

Please advice thanks mate in advance and let me know if you are able to have access to my shared drive.

Have a nice day , ciao



Thank you for the information! However, I’d suggest avoiding the sharing of files here, as it’s a public forum and anyone can check the troubleshoot files, that can contain some sensitive information.
As for the issue itself,everything looks fine from the router side - it connects to the carrier and receives an IP address. I suggest checking this SIM in your phone and verifying that it works.
Additionally, the signal is quite bad, with RSRP value of over -100, and SINR value of -5, so I’d also suggest checking the placement of the device, as well as ensuring that both antennas are tightened properly, since with this signal level even if internet connection will be available, it will not be of very good quality.

Best regards,

HI Daumantas , first of all thanks mate for your prompt replay , I will check the installed (Fasweb) SIM in the router and check it. Additionally, I have another SIM of another provider that I could check.
The only thing I forgot to add is the Teltonika RUT955 is installed on a VW T6 minivan , the antenna is installed on the pop top roof and is a Poynting PUCK-5 antenna ( 5-IN-1 TRANSPORTATION & IOT/M2M ANTENNA -### 617 - 4200 MHz; 2X2 LTE (MIMO), 6dBi; 2X2 Wi-Fi (MIMO), 7.5dBi; GPS/GLONASS, 21dBi). I will check the cables too.

Thanks for now I will keep you and the Team posted,have a nice day ahead , ciao



Sure, let me know how it goes!
Poynting makes high quality antennas, so I doubt that the antenna is an issue. Just make sure that the cables have not been damaged.

Best regards,

Hi Daumantas , I did several additional tests ( please refer to the folder “new tests” for logs and RUT955 configurations snapshots) using two SIM’s one the original one i.e. FASTWEB ( in roaming ) and a new one SWISSCOM ( not in roaming ) . Before inserting the second (new) Swisscom SIM on RUT955 I double checked if it was able to be connected to internet through 4G network and it was ( I did a 4G speedtest and inserted it in a cell phone ). Unfortunately the RUT955 is NOT able to be connected to internet with BOTH the SIM’s despite it shows “4GLTE connected”. I did the following tests :

1# RUT955 installed on my minivan and connected to Poynting 5:1 PUK 5 antenna ( it was working perfectly for 1 month)
a) tried (again) FASTWEB SIM ( original, in roaming ) and captured the real time log using CLI logread command ( see 07 Oct. logread Fastweb SIM) no internet
b) tried to CLEAN with isopropyl alcohol LTE PUK 5 antenna connectors , no results
c) tried a NEW tested SIM that was working perfectly on a cell phone (SWISSCOM) NOT in roaming ( same results , connected but NO internet at all , see Swisscom SIM logread 07 October 2023 and Swisscom

2# RUT955 “bench install” using original antennas and power supply
I disinstalled the router from my minivan and installed it on the bench using its original components
a) tried again with FASTWEB SIM in roaming , no internet ( see FASTWEB SIM on the bench original and logread_FASTWEB SIM 08 October 2023) - For configurations snapshots see “RUT955 on the bench original antennas” doc file.

You will find all the data on the attached link

b) tried also to change the setting again as you suggested without success ( MUT , DNS etc …)

Do you have any other ideas ?
I am quite desperate since I tried almost everything except to RESET the router to “factory default”
What sounds very odd to me it worked perfectly for one month also with the former firmware.

It could be a modem issue ?
Do I have to reload (again) the firmware ?
Do I have to reset the router and install it “from scratch” i.e. without using the back up / restore function ?

Many thanks in advance for your help / inputs , have a nice day.



From what I can see from the troubleshoot files, it seems like the connectivity takes a while to establish, but it does establish successfully. A few things noticed from the provided files:

  • MTU is still set to 1500. Please try lowering it to 1350, and keeping it this way during the tests.

  • Fastweb APN was used with Swisscom SIM as well. Different operators require a different APN, thus make sure to set the correct APN for the Swisscom. Since this issue does not seem to be APN-related, Auto APN can be enabled again.

It also seems like too many firewall settings were removed, and the mobile interface does not have any firewall zone assigned to it. You can either:

Without firewall zones, the traffic will not be forwarded between LAN and the mobile connection. Since the issue does not seem to be related to the mobile connection itself, hopefully the firewall zones are all that is needed.

Best regards,

Hi Daumantas , first of all thanks mate for your prompt replay / inputs.
Regarding your comments :
1# I will set MUT = 1350
2# regarding the APN thanks for the reminder , I tried also AUTO APN and wothout success , unfortunately during my tests I have attached the log that probably was still related to the tests I did with FASTWEB i.e.
3# since I had some doubts regarding the firewall settings I eliminated them , I was not aware of the fact that the traffic is not fowarded between LAN and mobile if ALL the rules are cancelled , I will re insert the zones in the firewall and let you know.
I would like to point out that with the same settings - that I bener touched for one month - the router was working perfectly also with the former firmware , not sure what suddenly happened , this is the reason because I am lost now,

As I last resource I will reset the device to factory default.

Thanks and have a great week !



I’ll be awaiting your response regarding this issue. If it still does not work, I suggest contacting us privately so we can organize a remote troubleshoot session. If this is a suitable option, please contact your reseller, sales manager, or fill out the Contact Us form here: Teltonika Networks - LTE Routers, Gateways & Modems for IoT

Best regards,

Hi Daumantas good morning thanks and I am sorry for my late replay.

During my test I tried to change in Interfaces>advantage Settings> Mode from NAT to bridge ( see below) and now I am not able anymore to access the Router using the IP ( RUT955 loging IP ). Do we have a possible solution to solve this ? I tried to assign a static IP to my laptop like without success.

BTW the next step will be to RESET the router to factory default and to reconfigure it from “scratch” without using the back up. Any other additional inputs from your side ? I will keep you psoted.

Thanks for now and have a great weekend , ciao


This topic was automatically closed after 19 days. New replies are no longer allowed.

Make sure you have only one WAN interface on your PC. Setting a static IP and an appropriate netmask should make the device reachable even in bridge or passthrough modes.
If this does not help, I’m afraid a factory reset will be the best option here.

Best regards,

Thanks Daumantas , a FACTORY RESET and a new install from “scratch” i.e. without using the back-up / restore function solve BOTH the issues i.e. 4G connectivity issue and the “login issue”.

Thanks for your great support , have a nice day ahead !


1 Like

This topic was automatically closed after 12 days. New replies are no longer allowed.