RUT950 WAN interfaces - WebUI not in sync with RutOS

Hi,

I just updated my RUT950 from firmware version RUT9_R_00.06.x to version RUT9_R_00.07.06.3 , also in order to use the iOS App “RutOS”.
One use case is to easily change the used WAN interface depending on where the router is located by using the App.

I discovered the following:
In the WebUI I configured the priorities on the “WAN” tab initially, including the priorities of WAN interfaces and enable/disable specific ones.
Later I wanted to modify the WAN interface settings using the RutOS App. Surprisingly the priority was not identical to what I defined in the WebUI. Then I tried to disable one WAN interface, successfully the connection was not available any more.
Checking afterwards the status of the WAN interfaces using the WebUI again, the disablement of this specific WAN interface was not reflected. The status of the WAN interfaces is obviously not in sync between App and WebUI.

I tried to reload the WebUI, I closed the App completely … but the WAN status was not displayed identically.
I tested also by changing the WAN priorities, changing it either in the App or in the WebUI … the changes were not reflected on “the other side”.

To be honest, I am not shure which UI is telling me the truth currently.

How can I solve this issue?

Hello,

I’ve tested the RutOS application on iOS 17.3 with R_00.07.06.3 and it seems like everything is working as intended. Changing the WAN interface priority via the WebUI is reflected in the app after switching to a different menu and going back to interface menu. It should be noted, that the interface disabled/enabled status, as well as metrics (priority) does not update in the application unless you go to a seperate window and back.
It also worked the other way around - disabling WAN interfaces was reflected in the WebUI after a refresh of the webpage.
Could you make sure that you are using the latest RutOS app version? Previous versions may have compatibility issues with the newer firmware. The current latest app version is 1.8.10.

Best regards,

Thanks for the quick reply!

I have the latest App version (1.8.10).

I tried again, opening App and WebUI this morning, everything was in sync.
Then I tried to change WAN priorities and enable/disable - it worked and was in sync within seconds. Seemed to be a temporary issue, not reproducable …

Then I did the same with the “Failover” switch.
It synced but took about a minute to be reflected after several page reloads. Not nice, but it works.

Another issue:
I renamed the mobile WAN interface from the default name “mob1s1a1” to “O2_4G” in the WebUI on the “WAN” page (no further changes)
The new name was reflected in the App on the “Interfaces” page, but on the “Multi WAN” page the interface completly disappeared.
Now 4 interfaces are listed in the WebUI, only 3 in the App.
How can I get displayed the missing interface in the App page “Multi WAN” again?
And in the App on “Interfaces” page the interface “O2_4G” got the blue label “Wired” next to the name although the Type/Protocol says “Mobile” (the other mobile interface is labeled “Mobile” as expected).

And occasionaly I get the message “Failed to load network interfaces” in the App when jumping back fom “Multi WAN” to “Interfaces”. The button “Try again” loads the interfaces then.

Another observation:
When I renamed the mobile WAN interface, the WAN-Wifi connection was lost (“Status: down”) and did not reconnect automatically. I needed to rebbot the device to connect the Wifi again.

Question:
I assume to have several options to change the “Metric” (priority) of the WAN interfaces in the WebUI.

  • on the “WAN” page by drag & drop
  • clicking “edit” for the respective interface an entering a number in “Metric”
  • on the “Failover → MultiWAN” page in section “Mode - Failover” by dragging the lines underneath.
    These options seem to be identical / reduntant to me (are they?)

What I observed:
I changed interface “wan” on page “Failover → MultiWAN” to Metric “1
I jumped to page “WAN”, the interface “wan” is on 2nd position in the table.
Clicking then on “edit” → “Advanced settings” it shows “Use gateway metric: 3”.
(In the App it shows “Priority 1”)
Shouldn’t all this be in sync?

Hint for improvement of user interaction / UI:
Align the wording within WebUI and between WebUI and App.
In the WebUI it’s “Metric”, in the App “Priority”.
In The WebUI it’s either “Type” or “Protocol”, in the App "Protocol

This topic was automatically closed after 15 days. New replies are no longer allowed.