RUT950 shows connected, but no internet

I have another RUT950 which is suddenly not allowing internet access, despite showing “connected”. My other RUT950 is connected to the same 4G tower, has similar values under “Data Transmission” but DOES connect to the internet.
Where do I even start on this? :slight_smile:
Many thanks


The RSRP is rather weak and shows that there is no signal. Is it the same on the other device?

Could you also confirm whether both devices are running the same firmware version?

Additionally, it would be helpful to know the firmware versions of the internal modems on both devices. You can find this information in Status → System.

Kind Regards,

The other modem is showing the same stats on RSRP.
Both modems are running RUT9_R_00.07.04.3
Both modems have the same internal firmware: EC25ECGAR06A04M1G_01.004.01.004
Only the bootloader is different, one is running 3.2.6 and the other 3.2.5.

I am not getting any help from the network operator whether the IMEI numbers are trying to authenticate.


The bootloader version is irrelevant.

Have you tried moving the device to a different location?

Maybe you have tried using a different SIM card or at least swapping the current SIM cards between the two devices?

What is the output of the following two commands on both devices:

  • gsmctl -A ‘AT+QENG=“servingcell”’
  • gsmctl -A ‘AT+QENG=“neighbourcell”’

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.