RUT950 doesn't work: no ssh access


I have a RUT950 and I’m having problems using it.
At first, I was able to display the main page where the router asks for username and password but I wasn’t able to enter the admin page since the router wasn’t able to load the main page.
However, I was able to connect via ssh, so I tried to upgrade firmware with the latest one. First time, it gave me a problem with the firmware image, however I forced it with -F.

Unfortunately, when the router finished the upgrading process, I wasn’t able to connect to it anymore.
Even if I use the ethernet cable, it seems that it is not possible to connect to it anymore. I tried both DHCP and manual configuration, but nothing works. I cannot load via ssh anymore and there is no Wi-Fi network. It seems like the RUT950 is dead. I also tried to reset it several times without any success.
All the for green leds blink all the time.

Since it is not possible to establish a connection with the router anymore, I think there are no possibilities to recover my router, is it correct?

Are there any other communications available on the RUT950 (like RS232) so I can use another method to upgrade or downgrade the firmware?

Thank you


I recommend trying these recovery options to address the issue with your device:

  1. Factory reset: A factory reset returns the device back to its default factory settings, i.e., it deletes all custom configurations.
  2. The bootloader menu: The bootloader menu is a special router state used as a recovery tool in case the router becomes inaccessible even after a factory reset. It can be used to upgrade the router’s firmware or bootloader version.

Please inform me if these steps help resolve the issue, and feel free to reach out if you require further assistance or guidance.

Best Regards,

Thank you for your answer. I already tried to do that before posting, but it didn’t work.

I’m sorry to hear that recovery options didn’t help. Most likely it is an issue which requires RMA (Teltonika Networks gives guarantee for its products for a period of 24 months).

I recommend reaching out to your sales manager or the reseller from whom you purchased the device for further assistance. Alternatively, you can use the ‘contact us’ form available here.

Please let me know If you have any further questions or require assistance.

Best Regards,

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.