RUT950 custom firmware


I’ve just moved to the latest FW (a.k.a. 07.04.5) and I want to change some settings and enable some services. I want to keep it simple and match the custom settings I’ve done in the legacy FW.
I’m following the sdk where there’s a section for selecting packages through the Kconfig. Is this the only way to enable/add a service i.e. MQTT?
Or could I download it from here packages or there’s no need to download anything and simply change some settings and values directly in the code?

In the legacy FW I had to change three files;

  1. package/base-files/etc/config/mqtt_pub enable and define IP/Port,
  2. package/base-files/files/etc/uci-defaults/73_mosquitto_migrate setting the mqttv5, and
  3. package/mosquitto/files/etc/config/mosquitto.

Now in the latest FW

  1. I imagine in the .config I have to set to y the CONFIG_MQTT_SUPPORT and CONFIG_PACKAGE_mqtt_pub and the vuci ones ?
  2. in the[ -n "$tls_type" ] || uci_set mosquitto mqtt bridge_protocol_version "mqttv5" ? and
  3. package/teltonika/mqtt_pub/bin/files/mqtt_pub.conf as in the legacy fw (i) and the package/network/services/mosquitto/files/etc/config/mosquitto with the port, version, enabled etc?

All the settings regarding the MQTT (enabled etc.) but the enable remote access seem to be set.
Although the enable_ra is set to 1 in the mosquitto conf for the broker, the GUI shows that it’s not set (or actually set to false). Another thing is that the default mqtt port is closed and only opens when the Enable remote access is switched to on in the GUI. I’m testing with nmap from a local PC the port on the router. Is this a bug or I missed something?


After spending a few hours in debugging, the issue was with the local port (mosquitto >= 2.0.0 by default binds localhost only). Not that straightforward as with the legacy fw but at least there’s a way around in the FW 07.04.5 (more complex but it’s there). :slight_smile:

This topic was automatically closed after 15 days. New replies are no longer allowed.