RUT360 low 4G speed

I just bought brand new RUT360 to upgrade from my Huawei MiFi.

But speed is 2x or more lower.

Tried on the same position, same SIM, at the same time (just few minutes difference for SIM change.)

I wanted to do an upgrade, with superb router from Teltonika, but now I’m very disappointed.

Huawei E5785 router gets 20-25Mbs down and 20 Mbs up.
RUT360 gets 5-20Mbs down and 5-10 Mbs up.

I bought RUT360 as an upgrade, but now it’s far from that.
Even Facebook Live have drops that are simply not acceptable.

On first screenshot are Bands on AUTO,
on second are on Manual (B20 disabled) and speeds are a bit better - 14 down, 10 up.

On manual it works better, but the problem is that this router is used in Motorhome and I change locations very frequently - many times a day.
Right now it is tested in my home spot where I use it most of the time, but when I travel, I really don’t want to manually test bands each time to find the one working. With old Huawei MiFi it worked automatically all the time.

Firmware and modem firmware are the latest:

  • Firmware version

  • Firmware build date
    2024-01-12 15:20:25

  • Internal modem firmware version

  • Kernel version

Screenshot 2024-02-03 193520


There could be many reasons for speed differences such as:

  • Differences in antenna design or placement;

  • Differences in connected bands;

  • Load of carrier cell towers;

It should be noted, that the Huawei device uses Cat 7 modem, which allows for higher theoretical upload speeds. As RUT360 uses external antennas, it should perform better in areas with worse signal coverage.
Additionally, for speed testing, I recommend using a PC connected to the RUT360 with a wired connection, as the speed testing utility on the RUT360 may show lower results than they actually are.
To properly compare the differences, could you attach the signal metrics from the Huawei device? This may help us determine the actual cause of speed differences.

Best regards,

Actually the speed is not the biggest problem right now.

The problem is that yesterday 3 times the router froze. Just stopped working. And was unreachable via so I had to pull the power plug out and back in to reboot.

I really can’t believe this.

Not to mention that when I was downloading some pictures from mobile phone to laptop (via WiFi, not mobile) the speed was 7Mbs (bits, not bytes). And after 3 pictures it froze and stopped working at all. Other two times I don’t remember what I was doing before if froze, but nothing special that I would not normally do with Huawei before.

I’m so disappointed with this router :frowning:


Does the device freeze regardless of the connected bands? What PSU is being used with the device? Is the primary connection to the device via WiFi or an Ethernet cable?
The device become “unreachable” if your device disconnects from WiFi once it stops providing internet access. This often occurs on Android and Windows devices, so make sure it’s not the case when the WebUI becomes unreachable.

Best regards,

Yes device froze while being on Auto and Manual bands selection.
For PSU it’s connected directly in my motorhome to LiFePo battery on 13,2V.

The connection is ONLY WiFi as its mounted on the window and is not reachable with cable.

The device became unreachable in the middle of downloading a picture from mobile phone to computer (via WiFi ridiculously slow - 7Mbit/s-that isn’t normal. With Huawei I was getting 25+Mbit easily).

It was still showing me that it was connected to WiFi while it became suddenly unreachable and had to be restarted manually. Even after waiting for 5 minutes, the WiFi was not available and I had to unplug it.

That is not even consumer stable, not to mention industrial stable.

Never in my life, I had to unplug and plug back any router to restart it. Neither did none of my routers stop working just in the middle of downloading.


I understand that this is not ideal, but would it be possible for testing to plug the router into the included 220V PSU and in turn connect the PSU to the 220V inverter?
It’s possible that voltage drops/spikes could induce such behaviour, and since the router is connected directly to the battery (and in turn the alternator, I assume).
Once again, this is only for testing purposes to see if providing stable power for the device would resolve the issues you’re facing.

Best regards,

The is no spikes in my motorhome as I am testing it while I’m stationary at home. No alternator charging. And even alternator does not give any spikes as with LiFePo battery there is constant 13,2V. When charging it goes slowly till 13,6V, so no spikes at all. The problem is I really can’t access it with 220V at the window where MiFi is located.

And also this unstable thing is not all the time. It’s random, so I can’t recreate it when I want.

I hope I will be able to return it back to seller and never Teltonika again.

This topic was automatically closed after 15 days. New replies are no longer allowed.