RUT360. Enabling MQTT and sending messages with mosquitto


I am connecting RUT360 router to Azure IoT cloud and using the following manual for it RUTX Azure IoT Hub cloud connection - Teltonika Networks Wiki

There is a step, which says:

First you will need MQTT broker to subscribe to, for testing purposes we will set MQTT Broker in same router, and will use PC from LAN to sent MQTT messages.
* Go to Services > MQTT > Broker
1. Click **Enable**
2. Use same port in MQTT Broker and Azure IoT Hub settings.
3. Press **Save**

But I don’t see MQTT option in Services menu. The only items which I see are:

  • Cloud Solutions
  • VPN
  • Mobile Utilities
  • Input/Output
  • Data to Server
  • Events Reporting

I have updated the firmware version and using the latest RUT36X_R_00.07.07.1

So I can not find where I can enable MQTT.


I found the way to enable MQTT - one needs to install the package first (though documentation doesn’t mention it)

But now there is next problem:

I am trying to launch mosquitto_hub command, but mosquitto_hub is not installed in the router.

root@RUT360:~# mosquitto_pub -h -p 8883 -m 'testing Azure MQTT messages' -t test
-ash: mosquitto_pub: not found

I tried to install it, but didn’t find strightforward way. Could you please suggest the proper way to install it?

Also it seems that there is a misprint in the documentation. It says:

mosquito_pub -h -p 8883 -m ‘testing Azure MQTT messages’ -t test

While mosquitto shall be written with 2 t - mosquitto as in screenshot provided in documentation further


You can find more information on a similar topic here.

Kind regards,

1 Like