RUT241 - Unable to connect to devices through VPN hub

I have RUT241 (FW: RUT2M R connected to some automation devices which I try to acces through RMS VPN hub.

They are all accessible through the local LAN if the RUT241 (PING and HTTPS) but NOT when I connect through the VPN hub. The hub is up and working. I have tried to delete the hub and make a new just to se if the problem was in the hub (German server).

The routes are setup according to the image below.

I also have a RUT240 in another location with the exact same automation equipment behind, which I can access without any issues. The settings of the RUT240 and 241 are seemingly identical.

Does anyone have any idea why it works on the RUT240 but not the RUT241? Is there some setting somwhere that I might have missed?


Your configuration seems to be correct.
I’ll ask you to post a screenshot of the General firewall setting on the RUT241 by navigating to Network → Firewall → General Settings. This may be able to help us determine if the issue could be on the router itself.
Additionally, could you try deleting the existing routes, and adding a route to the entire subnet?
Finally, make sure there are no IP conflicts on the PC you’re trying to access these devices from.

Best regards,

Hi Daumantas and thank you very much for your reply!
I have replaced the three routes with (, Still the same.
The general firewall settings are as shown in the image below.

I can’t find any IP confilcts. And since it works as soon as I change vpnhub to the one connected to the old RUT240, everything works fine (same devices and routes), I don’t think there is any issue on the current local network.

Thank you for the information.
I’ll ask you to open the General VPN Hub settings, check what IP address is assigned to the RUT241 (e.g., and try reaching that IP address using your PC with the connected VPN Hub. If you can reach the WebUI of RUT241, the issue is most likely with the routes (not being pushed to the PC, packets being routed to the incorrect interface, etc.).
Let me know if that is the case so we can continue troubleshooting.

Best regards,

Thanks! I checked the IP och the RUT241 ( and the PC ( Both respond to ping and the webUI is reachable.

Could you try running these commands via CMD:

ping -S
ping -S
ping -S

The -S argument will specify which interface to use to reach the devices in RUT241 LAN.
These commands are for Windows, but other OSes have an alterative argument as well.

Best regards,

Sure, but I think you mean “ping -S” since is the interface on my computer. Works on the RUT240 but not the RUT241.

I also tried to ping through the webUI, which works.

Apologies, yes, mixed up the addresses.
To diagnose the issue further, I’d need you to provide a troubleshoot file, which contains some sensitive information. As this is a public forum, that is not possible. Thus the only recommendation I could provide would be to either factory reset the RUT241 and check if the issue reappears after reconfiguring it, or delete the RMS VPN Hub, OpenVPN instance on the device, as well as the associated firewall zone and try again.
If that does not help, please contact your sales manager, reseller, or fill out the Contact Us form here: Teltonika Networks - LTE Routers, Gateways & Modems for IoT

Best regards,

Update! I found the error. The default GW of the devices was set to for some reson. Setting the GW manually to solved the problem.

A very simple error, but hard to find since the local network behind the RUT241 was working just fine. I hope this post helps someone else with similar problem. Daumantas, thanks so much for the fast support.

1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.