RUT241 - Configuration Wireless Mesh network

I have a problem with your RUT241 routers. I configured wireless mesh network like description in your Wireless Mesh configuration example [Wireless Mesh configuration example - Teltonika Networks Wiki], but the mesh network remains in down state (see document linked).

I have firmware RUT2M_R_00_07_06.1
Any suggestions? Thenks


Welcome to Teltonika Networks Community!

Usually, Wireless Mesh should work as long as you mirror the configuration from all Mesh Nodes. With that said, may I request the following screenshots to verify any misconfiguration?

  • General Set up of Mesh ID 1
  • Wireless Security (WPA3-SAE was used for all Mesh)
  • Wi-Fi Radio Channel (should be identical. Channel 11 was used in the document)

Looking forward to your feedback.


the mesh network configuration is like with example. I verified again it.
That are the screenshots requested.

Thank for your help


I tried to reconfigure Wireless Mesh on my side. A few takeaways are:

  • Wi-Fi Antenna should be properly inserted
  • Wi-Fi Radio should be 2.4 GHz
  • Wi-Fi Password should be identical to all routers

If everything seems to be correct but still not working, I suggest you restart the device to factory settings and reconfigure Wireless Mesh. Go to System → Maintenance → Back up → Restore Default Settings.

Let me know the results!


I have 2 routers RUT241, one configured like Mesh gateway and other configured like Mesh node, like indicated in example.
I checked setup and configurations fellow your indictions and I restarted the device to factory settings and reconfigure Wireless Mesh two time, but whithout success.

Do you know because in my routers is not possible choose DHCP protocol in LAN General Settings?

Thank you again for your help.


Apologies for the late revert. It seems that Wireless Mesh is not working with RUT2xx series on the latest firmware. I have tried to configure on RUTX series and found success. I will inform our developers about this and get back to you.



Our developers have reverted to me and was informed that it should be fixed on 7.07 firmware. Kindly watch out for our Wiki Page for new firmware releases.


This topic was automatically closed after 15 days. New replies are no longer allowed.