RUT240 WebUI login screen loading

Hello, I have a RUT240 that i just updated to the latest firmware but now I can not acces the WebUI I only can access via ssh. If I try to update firmware via clia it says Image Check failed.
Any help??
I already have updated the firmware several times but not working…


Could you please specify which firmware version you were attempting to upgrade from?
Additionally, please confirm if you were trying to upgrade to the RUT2_R_00.07.06.10 firmware version.

Best Regards,

Hello, thanks for your reply. In the past i was in RUT2_R_00.07.02.5_WEBUI.bin and now I am trying to install RUT2_R_00.07.06.10_WEBUI.bin Also I tried to reinstall the 07.02.5 but not working


In this scenario, device recovery options should prove beneficial:

  • Performing a factory reset restores the device to its default factory settings, effectively erasing all custom configurations.
  • Accessing the bootloader menu is a special router state utilized as a recovery tool if the router remains inaccessible even post a factory reset. It facilitates upgrading the router’s firmware or bootloader version.

Please let me know if these recommendations were effective. If not, we can delve deeper into analyzing the issue.

Best Regards,


I already tried a factory reset without being successfully. I have the same problem.

Where I can download bootloader file?? I have a firmware file but anything for u-boot. Can you send me the file?


Also, my router seems that has lost the name. The Wifi name is _002 and router name when I enter via SSH is Teltonika-
I hope that brings light to darknes :slight_smile:

Thank you for confirming that you have attempted a factory reset.

Regarding the router’s lost name, please log in to your router’s SSH via CLI and execute the command mnf_info -s . Check the output to ensure it displays the correct serial number (but refrain from sharing it here, as this information is sensitive). If the output shows the correct parameters, you should be able to proceed with updating the router. Sometimes, firmware update issues can arise due to lost router parameters. If the output does not display the expected parameters, it’s likely that we will need to arrange a remote session to further diagnose the issue.

As for the bootloader menu, you need to upload the firmware you downloaded from here. Please refer to the instructions and follow all the steps provided in this link to complete this process.

Let me know how it progresses!

Best Regards,

The comand mng_info -s shows a 000000
I recovered the name of the router with uci comand but nothing else… If i make a factory reset the name gets lost again.

The system says i can not upload things because i am a new user, but the firmware is the latest RUT2_R_00.07.06.10_WEBUI.bin


I’ve sent you a form to fill out for further assistance. Once completed, we’ll reach out to you privately to arrange a remote session and help resolve this problem. Please use ‘5231’ as the ticket ID

Best Regards,

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.