RUT240 unable to connect with Vodafone IoT Easyconnect

Hi everyone,

unfortunately my RUT240 won’t connect to Vodafone IoT Easyconnect. I want to use the service’s 2G/4G part for legacy IoT devices and gateways. The APN as per docs is “easyconnect.iot” and that should be it, no other auth required. I’ve tried almost all combinations of different settings and nothing. RUT gets registered I think but doesn’t connect to data (see the screenshot below).

I must use firmware RUT2_R_00.07.03.4 as that’s the last available for RUT230 and the configs need to be the same. As you can see from the attached log, it doesn’t get IP from the network.

Has anybody encountered this problem as well?


Welcome to Teltonika Networks Community !
Could you please confirm the below.

  1. Are you using RUT230 or RUT240 ?
  2. Did you try using any other simcards to check if the mobile connectivity is working as intended ?
  3. Can you try using the Auto APN and see the results if it varies ?
  4. Try using custom APN but make sure its all blank
    Clive Pinto

@clive.simon thanks for the quick response:
1 - All the configs are done on RUT240 but the setup will be also used on older RUT230s so I must use only the latest firmware available for RUT230. The devices will communicate with the same settings. So the debugging right now is done on RUT240.

2 - There was another SIM before so the devices was connected and working. I tried it with Soracom IoT SIM and it works all good (see the picture below 2G and 4G works with Soracom).

3 - Auto APN resulted in a different APN than what the docs say to use. But the device didn’t connect either. The result was the same.

4 - Nothing changes, no connection. See picture below


Auto APN

APN All blank

Sorry for the late reply, but this points to SIM card issue.There are 3 last things you can try from your end.

  1. Update the RUT240 to the latest firmware and try again.
  2. Try to use the SIM in any other device and check if you are connecting to it.
  3. Open the router CLI, login using credentials Username : root Password : “Device password” and enter the command “logread -f”, you try and findout why its not registering on the network.

Can also be that its using a Specific LTE Band not supported by the router.

Clive Pinto

This topic was automatically closed after 15 days. New replies are no longer allowed.