RUT240 seems bricked after firmware update attempt

Hello Teltonika Community,

I have a RUT240 which I had not used since 2019 until today.

Today I ran the web UI firmware update using the “from server” option and the web UI selected a version which is not the latest but definitely newer than what I had.

The firmware downloaded and the update seemed to succeed (got to 103%) and then the web UI went offline.

I tried to connect after restarting the device but could never connect.
I tried to do a factory reset but still unable to connect.
I then tried the Bootloader menu steps but still no success.

Any suggestions how to unbrick my device ?


Devices that haven’t been used may encounter various issues after upgrading to newer firmware. Significant firmware updates can potentially affect device functionality, especially if it’s transitioning from legacy firmware with existing settings.

If the device is unresponsive despite all attempted methods, it is likely “bricked,” as you mentioned. To confirm, could you describe the LEDs that light up when the device boots up? Additionally, try a few resets and reboots to ensure that the factory reset was executed correctly.

Feel free to reach out if you have any further questions.

Best regards,


Marijus, thanks for the reply.

In case it helps anyone in the future, I was able to unbrick my RUT240 following the steps here:

Thanks to Teltonika Networks, West USA support for providing the link.

This topic was automatically closed after 15 days. New replies are no longer allowed.