RUT240 firmware updates failing most of the time


we have multiple RUT 240 with various firmware versions running.

95% of the time I try to Update them to the newest firmware, either by uploading the .bin or let the RUT 240 download it from the server, the update is not successful. It always passes the FW verification and reboots, but after the reboot the router still has the exact same FW as before.

Generally the update attempts are from remote over IPSec using the WebUI.

Sometimes after a few failed attempts I try the same on site but with same result. Sometimes the updates finishes without error, but then the router factory resets itself, even though “keep settings” was enabled.

The other 5% of update attempts the router finishes this update without any problems (also on the first attempt, remote and on site).

Right now an update from to fails.

Anyone else facing this problem?

Probably not enough RAM to update the firmware, try to turn off some services that are not a must before upgrading, should help.

@pwsh RAM usage was between 85-90%. After I disabled ever service except dyndns and ipsec, RAM usage dropped to 80-85%.
FW Updates are still not executed.

What do you think, how much rum should be available? Currently ~ 10 MB are free.

10 MB free before or after uploading firmware? The firmware image itself is ~11MB, I would guess that you need to have free 15-21MB before upload since the firmware image is uploaded to RAM. That would leave 4-10MB free after upload. Maybe use top or download htop to see what is using so much RAM. You could also try to update via SSH using the sysupgrade utility. You would need to copy firmware image to RAM (/tmp/) and then execute sysupgrade [path_to_image] (add -n flag to not keep settings). Also you could check your disk usage with df -h to check maybe the actual flash storage is full or create a backup and see how much space the backup consumes, maybe there isn’t enough memory to restore your settings. Just spit balling ideas, but I know that RUT240 has low amount of RAM and that could be the reason.

This topic was automatically closed after 15 days. New replies are no longer allowed.