RUT240 Email event reports fail to send email

I want to setup event reports via email, but sending the email fails with a gmail address.

I setup a recipient in System / Administration / Recipients / Email users like in the screenshot attached. But sending a test email fails! What am I doing wrong?

The router is RUT240 with firmware RUT2_R_00.07.04.4.


For GMail, you need to enable 2-step verification, as well as create and generate an app password.There is a tutorial available online here.

Kind Regards,

Thank you! I was able to get it working by following that tutorial. Only that I didn’t have the “Add passwords” field, so I used this link to get there

Excellent thread, I followed all the steps but it hasn’t worked for me. (RUTX-50)

Is there any way of troubleshooting why the email isn’t being sent?

I have tried using the ‘test email’ button in the config as well as creating an event with an email notification and tried a real trigger but neither worked.

Sometimes I eventually get a notification to say the email wasn’t sent but most of the time nothing happens at all.

I’m stuck! Help!


Are you on the latest firmware?

Are you using Gmail? The settings should pretty much be the same as in the screenshots.

Kind Regards,

yes, latest firmware and I created a Gmail account specifically for this purpose and followed the instructions as per the screenshots.

Like Mitko, I found that Google have moved the “app passwords” since those screenshots were taken but other than that it’s exactly the same and I made sure I’m using the TLS port 587 as well.

I didn’t know if there was a log file somewhere that gave some idea of where it’s failing?

I also tried with a different mailserver (not Google) and got a test email to work, but not the real thing!!!


What triggers did you configure? Can you please show screenshots of these configurations?

I have tested and was able to send a test email using Gmail. Could you please double check if you have entered the correct password generated on the ‘app passwords’ page?

Kind Regards,

I set a notification trigger when a WiFi client joins or leaves.

I have a duplicate rule to send SMS and it works so the device is recognising the event happening.

The email account settings are below

I had copy / pasted the App password so am happy that it was correct but just to be sure, I created a new one. No change in behaviour.

I also tried selecting “mail” as the app and “other” as the device when generating App pass in Google, but this also made no difference.


Please try changing the STMP server ‘’ to ‘’. Let me know if it works then.

Kind Regards,


Such a simple thing after all these hours of testing! I can’t believe I made such a mistake.

Thank you, yes, that works perfectly.