RUT200 Wi-Fi Client mode


I am not an IT expert, so I need your help.

We have two PLCs that need to communicate over Wi-Fi network. Each PLC is connected to the RUT200’s LAN port, and RUT200 is connected to Wi-Fi network (RUT200 is in Client mode). Communication takes place via port 102.

What is the easiest way to do this?

Both RUT200 are connected to the Wi-Fi network as clients, but they cannot ping each other from CLI. I cannot ping them even from third device on that network (laptop). Other devices on the network i can normally ping. I wanted to forward port from wi-fi, but because i cannot ping RUT, i am stucked at the moment. So please help.


Thanks in advance.

Hello there,

  1. Could you clarify, when you connect to this Wi-Fi network, is it a public Wi-Fi or hotspot, where you need some sort of authorization? What type of router is it, it seems the firewall doesn’t let through any communication between other devices.

  2. What layer of communication does the PLC require?
    The reason we are asking this is because with the setup, that you are currently doing, this would make the PLC communicate at Layer 3 (Network level), thus the PLCs being in two separate LAN Networks and the traffic is routed over the internet (over wifi).
    However, there are a lot of PLCs and software, that come with them, which requires a Layer 2 (data link) communication. Usually, this comes down to the PLCs/software being able to send/receive ARP requests within the same Network. Automatically, they would have to belong to the same LAN subnet.
    We do have numerous methods of achieving this as well, however, first, we would need to know whether this type of communication is needed. If so, here are the options: OpenVPN TAP/Bridge mode, ZeroTier Bridge, WDS bridge, or Wireless Relay.

To achieve this setup you would need:

  1. To make sure that the device, hosting the WiFi Network, is not blocking the communication. On Teltonika devices, we have a Cllient-to-Client option available, once enabled, it allows Wireless clients to communicate directly. ( In your case, it seems that the two routers are unable to reach each other via the Wireless WAN IP addresses.

  2. Configure static routes, to each other’s LAN Network, on each of the RUT devices.

  3. Configure traffic rules, that would allow the necessary traffic, possibly two rules will be required on each device. One to allow protocol: ICMP Source Zone: WAN Destination Zone: LAN and another one to allow protocol TCP Destination port 102.

But please, note, that first, we would have to resolve that 1) issue, where the two Teltonika devices are not able to communicate through their Wireless WAN IP addresses. This most likely is caused due to the settings, that are configured on the Wireless network, possibly on the device, that is hosting that Wireless network. Do you have access to the device/network settings?

I will kindly wait for a reply from you.

In the meantime have a nice day,

This topic was automatically closed after 15 days. New replies are no longer allowed.