RMS VPN Quick Connect Germany server doesn't connect

Dear all,
I have tried to create a VPN Quick Connect, selected Germany server, then proceeded to connect with the Teltonika VPN Client, and it fails to connect.

However when I create another Quick Connect to the same router and same endpoint but selecting Virginia server, the client connects sucessfully and I’m able to reach the endpoint, albeit with a much higher latency as expected.

Does the Germany VPN server have any issues?

With regards
Niccolò Gallarati


Thanks for reaching us.

Actually, it appears that your locations are taking their time in attempting to connect to the Germany server location. You’ve already tried the Virginia server, which is connected but has a significant latency, which is also producing issues.

You can test the Bahrain server and let us know how it goes.

Furthermore, for testing purposes, I recommend that you use the VPN Hub option to create a VPN in Germany rather than Quick Connect, that will give us clear idea.

If possible, could you tell me where you are in you located “country”?

Links that may help:

Kindly let me know the results


I have created a VPN Quick Connect connection to my endpoint through the Bahrain server. The VPN client connected.

I try the Germany server, still error

I changed ISP and created new endpoints on a different RUT240 router. Bahrain and Virginia connect, Germany fails.

I’m based in Northern Italy.

I also noticed my Wi-Fi connection after these attempts is severed and have to manually reconnect despite it is set up to automatically reconnect. Maybe the virtual adapter is messing up something with the networking stack, but I’m no expert on this.

With regards


I tested the Germany server on my test bench and it worked great, therefore most likely your location is away from the Germany server, which is why there is an issue with it. For the time being, you can proceed with other servers if they are operating properly with no issues.


This topic was automatically closed after 15 days. New replies are no longer allowed.