RMS Failed after internal modem firmware

I just activated a new to me rut240 and had the RMS working for all of about 10 minutes. I initiated an internal modem update remotely only to have the RMS fail to connect after the update was finished. I have tried factory defaulting the system as well as removing it from the RMS console and re adding the device. I’m now running on 7.4.1 firmware just to see if an older version would work. The RMS console keeps saying that a device has attempted to connect to the system within the last couple of minutes, but the device is still listed as not activated. I’ve tried everything I can do but nothing works. factory defaults, new firmware, old firmware, but nothing works. I also want to note that the internet is working just fine through the router as I can surf the web etc.

Just un update on the current situation. The RMS console still shows that the device is attempting to connect every couple of minutes without success. under general information it shows my mac address, serial number, firmware version are all correct. The only think missing is the IMEI number. I’m just wondering if that number comes off the modem itself and is corrupt after the firmware update???

Did you re-put firmware version 07.06.11 via Bootloader Menu already?
Process described here:

RUT240 Firmware Downloads - Teltonika Networks Wiki

I was on that firmware when i did the internal modem update through the RMS console. I downgraded to an older version (7.4.1) just to try an older version. I could go back up to 7.6.11 just to see what happens. It’s weird because the RMS console does say that it sees the device try to connect from time to time. The RMS console also knows what firmware is currently on the device (7.4.1) so it seems to me that the device and RMS have talked to each other a little bit.

Hello,

Could you please upgrade to the RUT2_R_00.07.06.11 firmware version and try to re-add the device to RMS?
If it fails, could you please provide a screenshot of the error from RMS (remember to hide sensitive information like the serial number of the device) and a screenshot from WebUI under Services → Cloud Solutions → RMS?

Thank you.

Best Regards,

I updated to 7.6.11 last night.


Thank you for providing the screenshots.

Could you please check if you have a similar notification in Management → Devices next to your RUT240?
image

Best Regards,


#One is permanently off line. #two and #three work fine.
Device #four and #five are the 2 newest too me. I’m not sure if this matters or not but in order to get the RMS to work I have to use a sim card. basically I can’t get it to work via the WAN network slot. I used the same sim card in #five just long enough to see that it was working and then I used the same card in #four about 30 minutes later. It worked long enough for me to do the firmware updgrades and then quit. I guess I’m just wondering if the system has seen the same sim card used twice and it wont allow that. Obviously I know that i need separate sim cards but I just want to see both devices are working as they were previously used by someone else before i deploy them remotely.

Thank you for the information!

  1. To manage devices via RMS, they need to have internet access (whether from a SIM card, a WAN port via an Ethernet cable, or WiFi). Regarding the SIM, you can use the same SIM card in one device and then use it in another device without any issues.

  2. Could you please specify if you were referring to the WAN Ethernet port?

  1. You mentioned previously that you tried performing a factory reset and it didn’t help. Could you please try upgrading the firmware via the bootloader menu and check if the issue persists? Instructions on how to do this can be found on our wiki page RUT240 Device Recovery Options - Teltonika Networks Wiki.

I will be waiting for your feedback!

Best Regards,

I could not ever get any of the devices in my console to connect with RMS via the WAN ethernet port. I’m guessing something in my internet set up is the problem there. I always have to use a SIM card. I don’t care about the WAN ethernet port not working because I don’t use it when the devices get deployed since they run solely on cell service. Anyway I’m still trying to get #4 to connect via the SIM card, and the WAN ethernet is currently unplugged so the only possible communication path is through the SIM card.

hey I just looked in RMS and now #4 is working. I’m not sure why?

Hello,

It’s good to hear that your #4 router has connected to RMS!

It’s difficult to determine the exact problem, but it seems that your RUT240 was able to connect to RMS because it received internet from the SIM card.

Please let me know if you have any more questions or require further assistance regarding this topic!

Best Regards,