Remote access via mobile network

RUTX11 , I have trouble getting access via vpn mobile network and WEBUI.
I get the login page, and it looks fine.
But when I use the correct login . I get “The device is unreachable, Please check the connection a try again”
If I then try with a wrong login I get “Invalided user name…”

Login via ethernet wan is working fine !!

/Bo

Hello,

To be able to resolve the root cause of the issue, I would need some more additional information in this case:

  • What VPN are you using to connect to your router?
  • I would need a troubleshoot file from you, as it may contain sensitive information, I have sent you hubspot instructions to your email, where you will be able to communicate privately with us and there you will be able to share your troubleshoot file, check your inbox.

Access the router’s WebUI, navigate to SYSTEM → ADMINISTRATION (“MAINTENANCE” for firmware version 7.5 and later) → TROUBLESHOOT section, and download the troubleshoot file from there. Please ensure that the troubleshoot file is generated when the issue is occurring and before any reboot takes place so that it can be captured in the logs. For a more detailed guide you can refer to our wiki: RUTX11 Maintenance - Teltonika Networks Wiki (teltonika-networks.com)

Kindly waiting for your reply,
DziugasS

Sorry is not a VPN, but a private Apn.

I got a mail from you, with a link to a form. where I has to type in a ticket ID ?
But not a place to upload the troubleshoot file , and I have no Ticket Id !
/Bo

Ticket ID is 6623.
You can see this ID in the URL in your browser for this post here:

image

1 Like

How do I provide the troubleshoot file ?

I have tried to sent it via mail !

Hello Brihm,

Could you clarify about your private APN - Have you gotten private or public IP? Another question, does the device with private APN get internet access or is it made for internal communication?

If so, then there is possibility to reach your device over the internet using RMS or VPN setup, as it has a private IP address, unless you would ask your mobile provider to open a specific port to reach out your device, which would forward it to your devices IP and port. For more information about reaching your device remotely, you can refer to this guide: Remote Device Access - Teltonika Networks Wiki (teltonika-networks.com)

For more information regarding if your IP is public or private, you can refer to this article: Private and Public IP Addresses - Teltonika Networks Wiki (teltonika-networks.com)

As for the hubspot, you need to fill out the form that was sent to your email, your ticket ID is 6623.

If you have a private IP and mobile provider does not want to open the port for you via which you could access your device - then you need to get a APN with internet access and public IP address.

Let me know if you have any further questions,
DziugasS

Hi DziugasS,
It is a private network, no internet access and no closed ports,
We get the login page.
But when we type in the correct username and password. it say in red letters on the loginpage “The Device is unreachable, Please check the connection…” . If we type in the wrong password,it say in red letters “wrong password or username” Or something like that.

/Bo

Hello Brihm,

Thank you for providing the troubleshoot file to better understand the issue.

Firstly, I would offer to update the firmware version to the newest one, which would be RUTX_R_00.07.07.3. in this case. For information on how to update firmware version, you can refer to this article: RUTX11 Firmware - Teltonika Networks Wiki (teltonika-networks.com)

If it does not help and the issue persists, then remove the traffic rules named “webui” and “webui2”, as these overlap with already existing rules. After the removal, try connecting once again using the method that you were trying to connect through.

If this does not resolve the issue, then another step would be to change the mobile MTU sizes and testing it out with different sizes. Go to Network → WAN → edit mob2s1a1 interface → Advanced Settings section → Override MTU: 1440 then try connecting once again remotely and test, if this does not work, then change to Override MTU: 1400, test, if not then to 1300 and 1200, to see if it resolves the issue.

If after all of these steps you are still not able to connect remotely, then I would propose doing a remote session, where we would be able to look into this issue more in-depth.

Kindly waiting for your reply,
DziugasS