Remote access of AP on LAN (RUTX50)

Hi @Daumantas. Perhaps you can help me out here. I like to access AP’s in my LAN network to change parameters or reboot them. If I am local I can easily access those AP’s or routers by logging in via their webui. No problem.

Theoretical this should work exactly the same via the functionality as given in the RMS (Remote access) but I failed to do so. I can give the IP address, protocol and port nr and that should be it (normally http and port 80). I have tried different ones in the list but never got access.

What do I do wrong? I have tried some port forwarding but also no results. Perhaps I have some setting wrong somewhere…

Any idea?


RMS connect (remote access) does not require any port-forwarding rules on the router.

If you’re experiencing issues, is it specific to RMS Connect? If yes, have you attempted to add the host manually rather than using the auto-scan feature?

Moreover, have you tried connecting to other devices? Does that work? You can even attempt to reach your router through its LAN IP address using port 80 HTTP.

Are there any specific errors that occur when you try to connect?

Unstable internet connectivity can also be the cause of this issue.

What browser are you using? Have you tried clearing browser’s cache?

If you want to remotely manage your LAN devices, VPNs are a reliable option. You can choose to use RMS VPN or explore other VPN solutions. In case you don’t have a public IP address, ZeroTier is a good alternative as well. We even have a configuration example available for ZeroTier here.

Kind Regards,

Let’s take it point by point. I raised this issue in the ‘old’ forum but was not been able to complete it since it crashed at the time.

The first point (manually or auto-scan) I don’t understand. I just add the AP from the port list, fill out the specifics and add it to the remote list. When using it I get almost the login screen. So TP-Link logo appears but before the login starts I get an everlasting windmill.

So it appears that I am almost there… close but no cigar.

I have another host which I can connect to on port 80. No problem.

No error messages whatsoever.

Connectivity might not be great but is not giving any issues with the remote access to the router itself or another host (just one) connected to the router.

I cleared the cache. No impact.

In the ‘old’ forum I tried VPN. Your description in the manual is rather poor. I lost my connection to the router by ‘installing’ the VPN and I never got it back until I was local and restart the connection via the webui of the router.
On top of that I truly don’t understand why that should work. I have the impression it gets even more complicated. If there is an IP / Port issue why should the VPN help?

But really you offer this functionality on this router but why doesn’t it work a bit more fail safe. Somehow there seem to be always these gremlins in the system which just make it a disaster. Nothing first time right!

I have other ones:
Commands by SMS. Never got it to work…
and RMS VPN. I don’t even go close. Last time big disaster…

And while I am writing this. I upgraded it to latest firmware. Did a reboot and it doesn’t restart. Since I am not local I have have to ask my wife tonight to powercycle it… The thing drives me crazy :confounded: :weary: :tired_face: :triumph:

Nothing seems to work flawless with the shitty router :rage: Everything is a battle…
Thank you guys, great job, well done :sob:



It appears that RMS Connect is working since the connection is established with another device without any problems. The initial connection to TP-Link is also successful. You can try lowering MTU on the mobile interface to see if it makes any difference. However, if you are facing issues connecting to the TP-Link device, it might be related to specific settings on the TP-Link itself. Have you considered trying HTTPS (port 443) if it is supported by TP-Link?

In relation to VPNs, the objective is not to fix RMS Connect (it connects) but rather to establish secure remote access to your local network from anywhere. The issue you had with VPN is likely related to VPN configurations.

About SMS messages. Can you confirm whether you can successfully send and receive SMS messages from the device? Are there any issues specifically related to mobile utility commands?

Regarding restarts and freezes. How are you powering the device? What PSU are you using? Where is the router placed? Also, it seems that you are monitoring a lot of stuff. Do you monitor the temperature by any chance?

Kind Regards,

Yes the RMS is working and I have no issues with connecting to the router either via http or ssh. I have a remote connection to a raspberry P4 and also smooth. I am trying to get a connection with the TP-links for changing parameters and evt reboot. I got some very poor lan performance. However and fair is fair after the initial problems loading the latest firmware the LAN performance is almost picture perfect. No clue if it is related but it looks much better.
Solid grey or yellow is a good connection. The black lines or black parts are loss of connection:


I also monitor the rssi of all iot devices and it looks healthy as well!

The mobile connection has been stable (although speeds have been still very low) for the last apprx 24 hrs. So who knows its getting better!

I will try lowering the MTU (what would be a good nr? Default is 1500 as far as I know)
I have tried HTTPS and port 443 but the same effect. I am not local but once I am I might change the TPlink port from 80 to 8080. Perhaps there is some kind of conflict.

The SMS I have tried. Initially meaningless sms (like ‘hi’) would come through and appear in the inbox. Messages with a command would not appear at all but also not give any returns or results. I left it for some weeks. When I tried it again recently the commands end up in the inbox but not return of results.

I tried with and without password. No effect. The sending part doesn’t work. I can’t send SMS from the router.
Any way still not working and it takes a lot of time trialing. So I gave up. A nice to have if it works…

The VPN seems another nice to have but fails to work. Also I tried and I lost my RMS connection as a result. I find the instruction the manual in combination with a youtube instruction so massively clumsy that I don’t go near anymore. I just don’t trust that it works well.

Finally my device is powered on the grid directly with Teltonika charger. I have a small server ‘room’ where all ethernet and antenna cables lead to and where I have the raspberry P4 as well and some other stuff. The temperature of the router is always relatively high:
Around 65 degrC. The raspb in the same location is much more stable at 50 degrC.

By now I do have some serious doubts about the router but let’s see how it behaves in the coming days. The benefit of the doubt…

The statement: “Professional networking equipment with cellular 4G and 5G LTE and Wi-Fi connectivity for challenging enterprise, IoT, M2M, and Industry 4.0 applications.” is still a very very long way from home!


The MTU value depends on your operator and his mobile network. Thus, I would suggest trying different values to see if there are improvements.

For SMS messages, can you perform the following checks and tests for troubleshooting?

  • Insert the SIM card into your phone and check if you can send SMS messages from it. Ensure that the APN on your router matches the APN on your phone.
  • If you can send SMS from the phone, manually change the VOLTE setting to ON or OFF in Network → Mobile, depending on your operator.
  • If the issue persists, try setting the network type to 3G and see if it allows you to send SMS.

Regarding the SMS utilities, the correct syntax should be:

  • password status

The word ‘send’ is unnecessary.

For the freezes, it’s possible that overheating or power issues are causing the problem. To test this, try placing the router in a different room, away from direct sunlight.

Moreover, if available, test the router with another PSU. Additionally, consider powering the RUTX50 via Passive PoE to see if it makes any difference. Power information for RUTX50 can be found here.

Also, it seems that placing the router horizontally has helped one of the users here. Thus, please try placing the router horizontally for the testing purposes.

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.